Support Questions
Find answers, ask questions, and share your expertise

Namenode unable to start - Ranger issue in namenode HA configuration

Super Guru

I have namenode HA configured with Kerberos authentication, when ranger hdfs plugin is disabled, my hdfs services are running fine, when I enable ranger HDFS plugin then my namenode is unable to come up because of below error:

File "/usr/lib/python2.6/site-packages/ambari_simplejson/", line 353, in raw_decode raise 
ValueError("No JSON object could be decoded")
ValueError: No JSON object could be decoded 

I know there is know issue - if we change ranger admin UI password, then we also need to modify the same password in admin_password field under advance_ranger_configs section via Ambari UI. I tried doing the same thing but its not working.

Anyone has any idea or has seen this issue in past ?



Can you look into ambari and hdfs logs and check whether their is any message that has more details, especially what file/object Ambari is trying to decode?

Do you see a repository for HDFS in Ranger?

I have a cluster with NN HA and Ranger HDFS plugin enabled running on HDP 2.3.2 and Ambari without any issues.

Edit: What version of HDP and Ambari do you have?

Super Guru

Sure I will check. I have HDP 2.3.2 and Ambari 2.1.1


Can you make sure that the password for amb_ranger_admin in RangerAdmin->User is the same as in Ambari -> Ranger -> Config -> Ambari Admin User

Super Guru

I tried changing password for amb_ranger_admin however no luck. will update you once I get it working


@Kuldeep Kulkarni has this been resolved? Please accept best answer or provide your own solution.

Expert Contributor


I came across your problem and it seems to be a major issue. I've posted a question regarding this issue. We use Ranger for managing hive authorizations - and after changing the Ranger Admin password we can no longer use it for that. To be more precise - HiveServer2 won't start unless we disable Ranger as the authorization manager for hive in Ambari. More details in my post:

I really hope someone will fix this bug.


New Contributor


I'm having the same problem.

After changing ranger admin password in ranger & in ambari (under ambari ranger config) hive server won't start.

I get No json object could be decoded.

Only if I disable ranger from hive authorization it starts.

Hdp 2.3.2


Any help would appreciated.


Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.