Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 01-21-2025 11:30 PM
I am trying to integrate NIFI with Solace event broker and have created JMSConnectionFactoryProvidor service, which is enabled and running. However my JMSConsume processor gives this error -
ConsumeJMS failed to process session due to Host not specified;
Below are the configs for my FactoryService and processor:
What am I missing in the configuration?
Thanks.
Created 01-22-2025 09:13 AM
@amitjha
Providing the full stack trace from the nifi-app.log may help here in identifying the issue.
Is the controller service enabled and valid?
any other exceptions in the logs related to either the consumeJMS processor or the JMSConnectionFactoryProvider controller service?
The connectionFactory will on attempt to create the connection once first referencing component request a connection. The exception eludes to and issue there, but full stack trace may help identify exactly what went wrong.
Have you tried this tutorial from Solace:
https://solace.com/integration-hub/nifi/
Other observations:
Thanks,
Matt
Created 01-23-2025 11:32 PM
Thanks for the prompt response. We are working to get the stack-trace logs and would get back to you.
Thanks,
Amit.
Created 01-28-2025 02:49 AM
Hi Matt,
This is the error, we receive in the log:
Thanks,
Amit.