Support Questions

Find answers, ask questions, and share your expertise
Welcome to the upgraded Community! Read this blog to see What’s New!

NiFi boot problem versions 1.13+

New Contributor

Hello everyone, first of all, sorry for this question, I am completely new to the NiFi world and the problem should be something trivial, but I am currently at a complete loss. 


I have a VPS running on AWS, and I just wanna to deploy a NiFi instance, simple as possible. Just to continue my Data Engineering studies.


After running ./ start, I can access NiFi without any problems using http://EC2_IP:8080/nifi. But it works on versions up to 1.12.1. Version 1.13.2 and above, starting NiFi and trying to access using http or https://EC2_IP:8443/nifi does not work. Displaying a connection refused error in my browser.


8080 and 8443 are open on the instance security pannel, and all NiFi settings are on default, with no changes. I just wanna to unzip the bin file and run, close the SSH and access NiFi through my laptop. 

My EC2 instance is running on Ubuntu 22.04.3 LTS, UFW is disabled and Java seems to be correctly installed and JAVA_HOME is correctly setup. 


Am I missing any additional step to make this works? Thanks!


Community Manager

@gbrfilipe Welcome to the Cloudera Community!

To help you get the best possible solution, I have tagged our NiFi expert @steven-matison  who may be able to assist you further.

Please keep us updated on your post, and we hope you find a satisfactory solution to your query.


Diana Torres,
Community Moderator

Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.
Learn more about the Cloudera Community:

Super Collaborator

@gbrfilipe You should be able to very easily install 1.21 on a new machine with ssl enabled.  When you do the first startup, nifi will report out the user and password required in the app log:



Generated Username [75db8691-953c-4b96-b488-da2d3abf1b9d]
Generated Password [GHl/n4A7RUBKsM48TO0sLxjElR9HJPsR]


You would swap in your EC2 instance host.    


If nifi is running, and you are still unable to access it via the EC2 host, this is most definitely aws firewall configs.    I would not use an old version or non https nifi to evaluate.

New Contributor

Hello @steven-matison , thanks for your reply!

I was able to install RDP on my EC2 instance and access the NiFi UI successfully.

How can I make it accessible using my browser and not accessing EC2 through RDP?