Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

NiFi connected via WebUI but without communication with CM

avatar
Explorer

In the development cluster, the NiFi nodes do not show data or connection to Cloudera Manager, but if I access them via WebUI, the nodes appear properly connected and functional. Attached are NiFi logs and screen prints as evidence Previously I was instructed to review the Ranger policies as described in the Cloudera documentation, but the problem persisted, attached are the current Ranger settings. I also found the following error curious: Cookie rejected [hadoop.auth=""u=nifi&p=nifi/[email protected]&t=kerberos&e=1721689709429&s=qJPbU6hDNqLtkL1BokMp...", version:0, domain:v321d175.prevnet, path:/solr/ranger_audits_shard1_replica_n1, expiry:null] Domain attribute "v321d175.prevnet" violates the Netscape cookie specification However, in the prod cluster the same error appears in the logs and I don't have this problemStatus-NiFiNodes-CDP-Dev-17072024-10h32m (2).PNGStatus-NiFi-Cluster-Dev-17072024-10h32m (2).PNG

2 REPLIES 2

avatar
Master Collaborator

If I understand correctly,  Service NiFi works fine but from the Cloudera Manager things do not look promising this has to do with how CM monitors the NiFI service 

I would start to at the logs directory under the NiFi processor directory on each host where niFi is running and look for file connectionMetricOutput.log 

NNNNNNNN-nifi-NIFI_NODE/logs/connectionMetricOutput.log

On each Node where NiFi service is running, CM agent invokes nifi cli command get-nodes to get the health status of each node.

bin/cli.sh nifi get-nodes

If you find get-nodes command is not completing, you may want to further file a support case with us to look in detail. 

I hope this helps.

Thank you 

avatar
Explorer

Hi @ckumar ,

I couldn't find the command, would it be in the parcels path as shown in the attached printout?

 

nifi command.png