Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 05-18-2021 08:44 PM
Hi all,
I upgrade my nifi from 1.10 to 1.13.2 and i faced an error as the image below:
I tried find and fix with a lot solution, but i cant put the json into my mysql database.
Any one can help me?
Thanks
DuongNT
Created 05-20-2021 12:02 AM
Dear all,
Are there the big change in the processor Putdatabaserecord?
All my flow with this processor is error: Error index, error with the input string (although they are all string) ?
Or i miss some configuration in this version?
Or i cant use this processor with mysql?
Thanks
DuongNT
Created 07-12-2021 07:03 AM
Did you find a fix? Just upgraded from 1.12.2 to 1.13.2 and got a lot of these errors.
PutDatabaseRecord[id=af45e8dc-985b-3f7a-5959-539aa4e7fe9d] Failed to put Records to database for StandardFlowFileRecord[uuid=a398eafb-1fba-441c-81bc-c50509b74ed4,claim=StandardContentClaim [resourceClaim=StandardResourceClaim[id=1626097496241-29, container=default, section=29], offset=171430, length=172],offset=0,name=a398eafb-1fba-441c-81bc-c50509b74ed4,size=172]. Routing to failure.: Operand type clash: int is incompatible with datetime2
PutDatabaseRecord[id=08642c9d-0ce6-3277-79ec-fd5dc8990ba9] Failed to put Records to database for StandardFlowFileRecord[uuid=47f06505-9a47-40c2-b708-21c76466a555,claim=StandardContentClaim [resourceClaim=StandardResourceClaim[id=1626097496241-29, container=default, section=29], offset=174092, length=433],offset=0,name=50e9f73b-c3ee-4d22-8bde-4c2ec306400a,size=433]. Routing to failure.: For input string: "nifi2"
PutDatabaseRecord[id=3287e964-c2fb-3cff-345a-d0c11af60271] Failed to put Records to database for StandardFlowFileRecord[uuid=5d060b61-93ef-497b-983c-ef51596202cd,claim=StandardContentClaim [resourceClaim=StandardResourceClaim[id=1626097434922-28, container=default, section=28], offset=683211, length=377],offset=0,name=177de348-4f8c-4ce1-b450-c0eb45b51c9e,size=377]. Routing to failure.: The conversion from String to DECIMAL is unsupported.
Created 07-12-2021 07:28 AM
The only fix I've found so far is to update the Record Reader of this processor:
* Make sure it is not inferred
* Write the schema with the order of the record fields matching the order of the table fields.
I'm not sure if there was a reason this was changed or of this is a bug?