Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Nifi Cluster Start up issue :- server.quorum.QuorumPeerConfig does not have the form host:port or host:port:port or host:port:port:type

Solved Go to solution

Nifi Cluster Start up issue :- server.quorum.QuorumPeerConfig does not have the form host:port or host:port:port or host:port:port:type

Expert Contributor

HI All ,

I have created 2 nifi instances on Google Cloud Platform. I now plan to bring them onto a cluster. However I am getting this error

server.quorum.QuorumPeerConfig does not have the form host:port or host:port:port or host:port:port:type

I have checked my zoo keeper properties file again and again but not sure whats the issue. My zoo keeper properties file is as follows . I am not sure as to why this issue is cropping up. My nifi servers are by the name nifi-server2 and nifi-server1 and ports are 2888 and 3888 . I have followed the documentation by Pierre Villard.

server.1=nifi-server2:2888:3888

server.2=nifi-server1:2888:3888

# server.3=nifi-node3-hostname:2888:3888

Can someone please help me here.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Nifi Cluster Start up issue :- server.quorum.QuorumPeerConfig does not have the form host:port or host:port:port or host:port:port:type

Expert Contributor

Got this fixed now :-) . Actually there is an extra line in the zookeeper.properties file which is right at the end and that line creates an issue . It just needs to be deleted and this will then work like a charm .

5 REPLIES 5

Re: Nifi Cluster Start up issue :- server.quorum.QuorumPeerConfig does not have the form host:port or host:port:port or host:port:port:type

New Contributor

Hi @Abhinav Joshi, I am also configuring NiFi cluster with 3 machines (1 Manager and 2 Nodes) but could not be able to configure it yet. Can you share some useful link in this regard. My NiFi version is 1.8.0 and using external Zookeeper instead of embedded Zookeeper.

Re: Nifi Cluster Start up issue :- server.quorum.QuorumPeerConfig does not have the form host:port or host:port:port or host:port:port:type

Expert Contributor

Hi Rishabh , Have a look at https://pierrevillard.com/2016/08/13/apache-nifi-1-0-0-cluster-setup/

This one is really good . I have followed this although I am stuck . Waiting for Pierre Villard to respond

Re: Nifi Cluster Start up issue :- server.quorum.QuorumPeerConfig does not have the form host:port or host:port:port or host:port:port:type

New Contributor

I have tried this in my 2nd attempt but this is also not working for me. Cluster was created but no nodes were attached with this.

Re: Nifi Cluster Start up issue :- server.quorum.QuorumPeerConfig does not have the form host:port or host:port:port or host:port:port:type

Expert Contributor
Hi Rishabh , did you try shutting down the nifi instances and start them one at a time ?
Highlighted

Re: Nifi Cluster Start up issue :- server.quorum.QuorumPeerConfig does not have the form host:port or host:port:port or host:port:port:type

Expert Contributor

Got this fixed now :-) . Actually there is an extra line in the zookeeper.properties file which is right at the end and that line creates an issue . It just needs to be deleted and this will then work like a charm .