Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

Nifi - SelectHive3QL processor is throwing a Kerberos authentication exception

avatar
Contributor

I am using SelectHive3QL processor in my Nifi flow and it is throwing a below Kerberos authentication exception. Initially it is working fine for some time and after some Idle time, getting a below error. My requirement is "SelectHive3QL" should always up and running without any issues.

 

Exception:

SelectHive3QL[id=47753131-0b9a-39c4-b0e7-2a92ac1042c6] Issue processing SQL select * from egress_test where service_name = 'NDC' due to java.sql.SQLException: Could not open client transport for any of the Server URI's in ZooKeeper: GSS initiate failed.: org.apache.nifi.processor.exception.ProcessException: java.sql.SQLException: Could not open client transport for any of the Server URI's in ZooKeeper: GSS initiate failed

 

Cc: @MattWho , @arunak , @stevenmatison 

1 ACCEPTED SOLUTION

avatar
Master Mentor

@VijaySankar 

 

So, it is very likely you are hitting that bug.  If you have a support subscription with Cloudera, you can open a support ticket for a patched release of HDF 3.2.x based off Apache NiFi 1.7.  

If not, your best bet is to upgrade to NiFi 1.10.

Thanks,

Matt

Please take a moment to accept any answers which answered/resolved your query.

View solution in original post

5 REPLIES 5

avatar

Are you running a recent version of HDF?

This thread suggests it may be an issue that has been resolved: http://apache-nifi.1125220.n5.nabble.com/Hive-w-Kerberos-Authentication-starts-failing-after-a-week-...


- Dennis Jaheruddin

If this answer helped, please mark it as 'solved' and/or if it is valuable for future readers please apply 'kudos'.

avatar
Master Mentor

@VijaySankar 

 

What version of NiFi are your running?

It is extremely likely you have encountered following bug:
https://issues.apache.org/jira/browse/NIFI-6210

So if you are not running Apache NiFi 1.10 or newer, you are exposed to this bug specifically affecting the Hive 3 NiFi components.

 

Hope this helps,
Matt

avatar
Contributor

@MattWho Thanks for your response.

 

Our Nifi version is 1.7.

avatar
Master Mentor

@VijaySankar 

 

So, it is very likely you are hitting that bug.  If you have a support subscription with Cloudera, you can open a support ticket for a patched release of HDF 3.2.x based off Apache NiFi 1.7.  

If not, your best bet is to upgrade to NiFi 1.10.

Thanks,

Matt

Please take a moment to accept any answers which answered/resolved your query.

avatar
Contributor

Will do. Thanks.