Support Questions
Find answers, ask questions, and share your expertise

Nifi There is insufficient memory for the java Runtime

Solved Go to solution
Highlighted

Nifi There is insufficient memory for the java Runtime

Contributor

Hi,

I am currently facing issue with NiFi 1.7.0 (2 nodes),
My flows had been running fine since months. Couple of weeks ago we did a downgrading of the nifi machines. We went from CPU 16 RAM 128G to CPU 4 RAM 32G.
After the dowgrading we changed parameters to make sure that nifi take into consideration the new size of the machines

Initial values:
Initial memory allocation: 80G
Max memory allocation: 112g

New values:
Initial memory allocation: 20G
Max memory allocation: 26G

within nifi we did also change in NIFI Genaral Settings
from
Maximum timer driven thread count: 64
Maximum event driven thread count: 16
to
Maximum timer driven thread count: 2
Maximum event driven thread count: 4

Now some time when we try to load we get an enexpected error occured with

2020-08-18 10:57:51,942 ERROR [NiFi logging handler] org.apache.nifi.StdErr OpenJDK 64-Bit Server VM warning: INFO: os::commit_memory(0x0000000780000000, 218103808, 0) failed; error='Cannot allocate memory' (errno=12)
2020-08-18 10:57:51,956 INFO [NiFi logging handler] org.apache.nifi.StdOut # There is insufficient memory for the Java Runtime Environment to continue.
2020-08-18 10:57:51,957 INFO [NiFi logging handler] org.apache.nifi.StdOut # Native memory allocation (mmap) failed to map 218103808 byt

Could you please help me with this issue.

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Nifi There is insufficient memory for the java Runtime

@Koffi   If you have a nifi flow created and tuned at a very large spec, and you downgrade that spec, you are going to have all kinds of problems like you are experiencing.

 

You are going to need to go into the flow and reduce concurrency and min/max thread pool settings and completely re-tune the flow for the new environment since you reduce the ram and per core of the nodes.   Another suggestion is that nifi 1.7 is very dated.  You should consider an upgrade to nifi 1.12 and use at least 3 nodes.

 

 

If this answer resolves your issue or allows you to move forward, please choose to ACCEPT this solution and close this topic. If you have further dialogue on this topic please comment here or feel free to private message me. If you have new questions related to your Use Case please create separate topic and feel free to tag me in your post.  

 

Thanks,


Steven @ DFHZ

View solution in original post

2 REPLIES 2
Highlighted

Re: Nifi There is insufficient memory for the java Runtime

Cloudera Employee

@Koffi  Can you try to lower the initial memory and restart the service please?

Re: Nifi There is insufficient memory for the java Runtime

@Koffi   If you have a nifi flow created and tuned at a very large spec, and you downgrade that spec, you are going to have all kinds of problems like you are experiencing.

 

You are going to need to go into the flow and reduce concurrency and min/max thread pool settings and completely re-tune the flow for the new environment since you reduce the ram and per core of the nodes.   Another suggestion is that nifi 1.7 is very dated.  You should consider an upgrade to nifi 1.12 and use at least 3 nodes.

 

 

If this answer resolves your issue or allows you to move forward, please choose to ACCEPT this solution and close this topic. If you have further dialogue on this topic please comment here or feel free to private message me. If you have new questions related to your Use Case please create separate topic and feel free to tag me in your post.  

 

Thanks,


Steven @ DFHZ

View solution in original post