Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Nifi UI not launching

Solved Go to solution
Highlighted

Nifi UI not launching

Expert Contributor

Hello

I have downloaded HDF in a centos 7 machine and i have started the service. When i run bin/nifi.sh status, i get the following

Nifi is currently running, listening to Bootstrap on port 40883, PID=18516

However when i enter http://<servername>:8080/nifi the UI fails to appear. Is there anything i am missing? Please advise

Regards

Ahmad

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Nifi UI not launching

@Ahmad Debbas

As always, start by checking your most recent /logs for ERROR or even WARN, e.g.:

cat nifi-app* | grep ERROR

Logs are: nifi-app*.log, nifi-bootstrap*.log, nifi-user*.log

View solution in original post

17 REPLIES 17
Highlighted

Re: Nifi UI not launching

can you check nifi bootstrap logs to see if there is any port conflict.

Highlighted

Re: Nifi UI not launching

Expert Contributor

Please find below the bootstrap log

2016-05-31 09:40:05,021 INFO [main] o.a.n.b.NotificationServiceManager Successfully loaded the following 0 services: []
2016-05-31 09:40:05,027 INFO [main] org.apache.nifi.bootstrap.RunNiFi Registered no Notification Services for Notification Type NIFI_STARTED
2016-05-31 09:40:05,027 INFO [main] org.apache.nifi.bootstrap.RunNiFi Registered no Notification Services for Notification Type NIFI_STOPPED
2016-05-31 09:40:05,027 INFO [main] org.apache.nifi.bootstrap.RunNiFi Registered no Notification Services for Notification Type NIFI_DIED
2016-05-31 09:40:05,035 INFO [main] org.apache.nifi.bootstrap.Command Starting Apache NiFi...
2016-05-31 09:40:05,035 INFO [main] org.apache.nifi.bootstrap.Command Working Directory: /opt/HDF-1.2.0.1-1/nifi
2016-05-31 09:40:05,036 INFO [main] org.apache.nifi.bootstrap.Command Command: /opt/jdk1.7.0_79/bin/java -classpath /opt/HDF-1.2.0.1-1/nifi/./conf:/opt/HDF-1.2.0.1-1/nifi/./lib/jcl-over-slf4j-1.7.12.jar:/opt/HDF-1.2.0.1-1/nifi/./lib/jul-to-slf4j-1.7.12.jar:/opt/HDF-1.2.0.1-1/nifi/./lib/log4j-over-slf4j-1.7.12.jar:/opt/HDF-1.2.0.1-1/nifi/./lib/logback-classic-1.1.3.jar:/opt/HDF-1.2.0.1-1/nifi/./lib/logback-core-1.1.3.jar:/opt/HDF-1.2.0.1-1/nifi/./lib/nifi-api-0.6.0.1.2.0.1-1.jar:/opt/HDF-1.2.0.1-1/nifi/./lib/nifi-documentation-0.6.0.1.2.0.1-1.jar:/opt/HDF-1.2.0.1-1/nifi/./lib/nifi-nar-utils-0.6.0.1.2.0.1-1.jar:/opt/HDF-1.2.0.1-1/nifi/./lib/nifi-properties-0.6.0.1.2.0.1-1.jar:/opt/HDF-1.2.0.1-1/nifi/./lib/nifi-runtime-0.6.0.1.2.0.1-1.jar:/opt/HDF-1.2.0.1-1/nifi/./lib/slf4j-api-1.7.12.jar -Djava.net.preferIPv4Stack=true -Dsun.net.http.allowRestrictedHeaders=true -Djava.protocol.handler.pkgs=sun.net.www.protocol -Dorg.apache.jasper.compiler.disablejsr199=true -Xmx512m -Djava.awt.headless=true -Xms512m -Dnifi.properties.file.path=/opt/HDF-1.2.0.1-1/nifi/./conf/nifi.properties -Dnifi.bootstrap.listen.port=44940 -Dapp=NiFi org.apache.nifi.NiFi
2016-05-31 09:40:05,532 INFO [NiFi Bootstrap Command Listener] org.apache.nifi.bootstrap.RunNiFi Apache NiFi now running and listening for Bootstrap requests on port 40883
2016-05-31 09:44:07,595 INFO [main] o.a.n.b.NotificationServiceManager Successfully loaded the following 0 services: []
2016-05-31 09:44:07,599 INFO [main] org.apache.nifi.bootstrap.RunNiFi Registered no Notification Services for Notification Type NIFI_STARTED
2016-05-31 09:44:07,599 INFO [main] org.apache.nifi.bootstrap.RunNiFi Registered no Notification Services for Notification Type NIFI_STOPPED
2016-05-31 09:44:07,599 INFO [main] org.apache.nifi.bootstrap.RunNiFi Registered no Notification Services for Notification Type NIFI_DIED
2016-05-31 09:44:07,608 INFO [main] org.apache.nifi.bootstrap.Command Apache NiFi is currently running, listening to Bootstrap on port 40883, PID=18516
2016-05-31 10:14:10,626 INFO [main] o.a.n.b.NotificationServiceManager Successfully loaded the following 0 services: []
2016-05-31 10:14:10,633 INFO [main] org.apache.nifi.bootstrap.RunNiFi Registered no Notification Services for Notification Type NIFI_STARTED
2016-05-31 10:14:10,633 INFO [main] org.apache.nifi.bootstrap.RunNiFi Registered no Notification Services for Notification Type NIFI_STOPPED
2016-05-31 10:14:10,633 INFO [main] org.apache.nifi.bootstrap.RunNiFi Registered no Notification Services for Notification Type NIFI_DIED
2016-05-31 10:14:10,651 INFO [main] org.apache.nifi.bootstrap.Command Apache NiFi is currently running, listening to Bootstrap on port 40883, PID=18516
Highlighted

Re: Nifi UI not launching

New Contributor

Actually, I just have installed nifi locally (vmware) and have the same issue and came across this ;)

Highlighted

Re: Nifi UI not launching

Is the centos 7 system a VM? If so, is the port 8080 open?

Also, look in the nifi-app.log, it will list the URLs of the NiFi UI.

Highlighted

Re: Nifi UI not launching

Expert Contributor

i disabled firewall and it worked

Highlighted

Re: Nifi UI not launching

@Ahmad Debbas

As always, start by checking your most recent /logs for ERROR or even WARN, e.g.:

cat nifi-app* | grep ERROR

Logs are: nifi-app*.log, nifi-bootstrap*.log, nifi-user*.log

View solution in original post

Highlighted

Re: Nifi UI not launching

Expert Contributor

i disabled firewall and it worked! thanks

Highlighted

Re: Nifi UI not launching

Master Guru

Ahmad,

The line you are seeing in the nifi-bootstrap.log indicates the JVM started successfully. You need to check the nifi-app.log to make sure the application loaded successfully. In the nifi-app.log you will find the following lines if the application successfully loaded: 2016-05-31 10:46:44,347 INFO [main] org.apache.nifi.web.server.JettyServer NiFi has started. The UI is available at the following URLs:

2016-05-31 10:46:44,347 INFO [main] org.apache.nifi.web.server.JettyServer http://<someaddress or FQDN>:8088/nifi

Verify that the hostname or IP displayed on this line is reachable/resolvable on the system you are running your web browser from.

Thanks,

Matt

Highlighted

Re: Nifi UI not launching

Explorer

I am facing the sam issue. I see this in the log. Not sure what it mean and how to fix? Still not able to launch nifi UI

2016-06-23 09:54:53,778 WARN [main] o.e.j.util.component.AbstractLifeCycle FAILED ServerConnector@c53209{HTTP/1.1}{0.0.0.0:8080}: java.net.BindException: Address already in use: bind java.net.BindException: Address already in use: bind

Don't have an account?
Coming from Hortonworks? Activate your account here