Support Questions
Find answers, ask questions, and share your expertise

Nifi error: Unable to save flow controller configuration

Explorer

krishna123_0-1647242982435.png

I'm getting same error again and again. Not able to resolve it. Can anyone help me in it. Nifi running in Linux server

 

1 ACCEPTED SOLUTION

Master Collaborator

Hi , @krishna123,

 

Thanks for the output! This explains the issue that you're seeing.

You mentioned before that you were using Java 1.8.0_275, but the log line you just provided shows that NiFi is actually using Java 1.8.0_74.

 

In this version of Java, cryptographic key sizes are limited and NiFi cannot not handle AES keys larger than 128 bits. Because of that, NiFi fails to instantiate AES iphers properly. To enable that in your Java version, you would have to download the Java Cryptography Extension (JCE) Unlimited Strength policies and copy them to your Java home manually to allow AES keys of size 256 and larger. These policies are only included by default in the JDK starting from update 1.8.0_162.

 

If you already have Java 1.8.0_275 installed, make sure NiFi can see it and use it. This will solve your problem. You can verify which Java version NiFi is using by checking the line that I mentioned in the log.

 

Cheers,

André

--
Was your question answered? Please take some time to click on "Accept as Solution" below this post.
If you find a reply useful, say thanks by clicking on the thumbs up button.
--
Was your question answered? Please take some time to click on "Accept as Solution" below this post.
If you find a reply useful, say thanks by clicking on the thumbs up button.

View solution in original post

18 REPLIES 18

Rising Star

Do you see the same error string in nifi-app.log ? or there are any additional information in applogs ? if you see more details, please provide.

Are you able to make any changes to flow design ?

Can you please permissions and space is fine where flow.xml.gz is placed?

 

Thank You.

Explorer

Hi @ckumar 

 

The flow changes made are not being saved in the Nifi. All read and write permissions are given to file flow.xml.gz.

I can see one error in nifi-app.log. "Error initializing the cipher". Below is the error. Is this causing the issue?

krishna123_0-1647258701169.png

 

Master Collaborator

@krishna123 ,

 

What's the Java version that you are using?

 

Cheers,

André

--
Was your question answered? Please take some time to click on "Accept as Solution" below this post.
If you find a reply useful, say thanks by clicking on the thumbs up button.

Explorer

@araujo ,

 

Java8

Master Collaborator

@krishna123 ,

 

What's the exact version? (java -version)

 

Cheers,

André

--
Was your question answered? Please take some time to click on "Accept as Solution" below this post.
If you find a reply useful, say thanks by clicking on the thumbs up button.

Explorer

@araujo 

java version 1.8.0_275

Master Collaborator

@krishna123 ,

 

Could you please provide the full stack trace of the exception you found in nifi-app.log?

 

André

 

--
Was your question answered? Please take some time to click on "Accept as Solution" below this post.
If you find a reply useful, say thanks by clicking on the thumbs up button.

Explorer

Hi @araujo 

 

Here it is:

krishna123_0-1647326168538.png

 

Master Collaborator

Could you please look into your nifi-bootstrap.conf and look for the line like the one below and paste it here?

 

2022-03-15 16:03:24,008 INFO [main] org.apache.nifi.bootstrap.RunNiFi Runtime Java version: ...

--
Was your question answered? Please take some time to click on "Accept as Solution" below this post.
If you find a reply useful, say thanks by clicking on the thumbs up button.

Explorer

@araujo 

Here it is:

krishna123_0-1647336377253.png

 

Master Collaborator

Hi , @krishna123,

 

Thanks for the output! This explains the issue that you're seeing.

You mentioned before that you were using Java 1.8.0_275, but the log line you just provided shows that NiFi is actually using Java 1.8.0_74.

 

In this version of Java, cryptographic key sizes are limited and NiFi cannot not handle AES keys larger than 128 bits. Because of that, NiFi fails to instantiate AES iphers properly. To enable that in your Java version, you would have to download the Java Cryptography Extension (JCE) Unlimited Strength policies and copy them to your Java home manually to allow AES keys of size 256 and larger. These policies are only included by default in the JDK starting from update 1.8.0_162.

 

If you already have Java 1.8.0_275 installed, make sure NiFi can see it and use it. This will solve your problem. You can verify which Java version NiFi is using by checking the line that I mentioned in the log.

 

Cheers,

André

--
Was your question answered? Please take some time to click on "Accept as Solution" below this post.
If you find a reply useful, say thanks by clicking on the thumbs up button.
--
Was your question answered? Please take some time to click on "Accept as Solution" below this post.
If you find a reply useful, say thanks by clicking on the thumbs up button.

Explorer

@araujo  How can I change the version of Java which Nifi is using?

Master Collaborator

@krishna123 ,

 

Check your environment path and Java Home settings. NiFi will pick the first Java binary that it finds in your path.

 

André

--
Was your question answered? Please take some time to click on "Accept as Solution" below this post.
If you find a reply useful, say thanks by clicking on the thumbs up button.

--
Was your question answered? Please take some time to click on "Accept as Solution" below this post.
If you find a reply useful, say thanks by clicking on the thumbs up button.

Explorer

ok Thanks @araujo 

Master Collaborator

@krishna123 ,

 

Did you manage to get your problem solved?

 

André

--
Was your question answered? Please take some time to click on "Accept as Solution" below this post.
If you find a reply useful, say thanks by clicking on the thumbs up button.

--
Was your question answered? Please take some time to click on "Accept as Solution" below this post.
If you find a reply useful, say thanks by clicking on the thumbs up button.

Explorer

@araujo No, could not fix the issue

Master Collaborator

@krishna123 ,

 

Are you able to uninstall the  Java 1.8.0_74 version?

 

André

--
Was your question answered? Please take some time to click on "Accept as Solution" below this post.
If you find a reply useful, say thanks by clicking on the thumbs up button.

New Contributor

Hi @krishna123

I have the same problem. Thank you for helping me 

; ;