Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

Nifi throwing SQLException after DB version update, same query worked in Nifi on older postgre version

avatar
Explorer

hkh_0-1696338566556.png

 

1 ACCEPTED SOLUTION

avatar

@hkh, your post lacks all the minimum information required for anybody to help you out. Nevertheless, based on your error message, it seems that you are trying to connect to a PostgreSQL Database.

Now, as you mentioned, you did an upgrade at the database level, meaning that some aspects have changed in terms of configurations. Your error message stats clearly what the issue is where you need to look to have it solved.

Unfortunately, this has nothing to do with NiFi, but to how your DBA Team has configured your PostgreSQL Instance.

Have a look here:
https://stackoverflow.com/questions/67588076/why-do-i-get-error-type-10-authentication-not-supported...

https://stackoverflow.com/questions/64210167/unable-to-connect-to-postgres-db-due-to-the-authenticat...

View solution in original post

2 REPLIES 2

avatar

@hkh, your post lacks all the minimum information required for anybody to help you out. Nevertheless, based on your error message, it seems that you are trying to connect to a PostgreSQL Database.

Now, as you mentioned, you did an upgrade at the database level, meaning that some aspects have changed in terms of configurations. Your error message stats clearly what the issue is where you need to look to have it solved.

Unfortunately, this has nothing to do with NiFi, but to how your DBA Team has configured your PostgreSQL Instance.

Have a look here:
https://stackoverflow.com/questions/67588076/why-do-i-get-error-type-10-authentication-not-supported...

https://stackoverflow.com/questions/64210167/unable-to-connect-to-postgres-db-due-to-the-authenticat...

avatar
Explorer

Thanks a lot for your response.