Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

No available Impalad to send queries to

Solved Go to solution

Re: No available Impalad to send queries to

Could you use the impala shell to connect to the impalad and give a try?

How about restarting just this impalad?

Re: No available Impalad to send queries to

Contributor
As I mentioned earlier, the impala shell works fine. I can connect and work with Impala without any problems.

Re: No available Impalad to send queries to

But do you connect to this exact same impalad?

Re: No available Impalad to send queries to

Contributor
Yes, I do.

Re: No available Impalad to send queries to

So I don't know. You could share the /logs page content after opening the
editor. Then see if restarting Hue would unfreeze it

Re: No available Impalad to send queries to

Contributor
Let me run a full restart in case something is hosed somewhere. I'll update the post as soon as I'm done. Thanks for your help.

Re: No available Impalad to send queries to

Contributor

Problem solved. Rebooting the cluster servers didn’t fix the issue. The problem was due to Hue being configured with LDAP. Even though I didn’t find anything that says otherwise, I didn’t think that Having LDAP implemented for Hue required Impala too to be configured for LDAP. After doing that the misconfiguration message disappears, and everything works fine.

Thanks again for your help!

Highlighted

Re: No available Impalad to send queries to

Expert Contributor
Just curious, what ldap properties did you have set for Hue? Hue being configured for Ldap should not force Impala to require Ldap.

Re: No available Impalad to send queries to

Contributor
That's what I thought too. However, the problem disappeared only after setting the following properties via Cloudera Manager in the Impala Command Line Argument Advanced Configuration Snippet (Safety Valve):
-ldap_allow_anonymous_binds=false
-ldap_domain=
-ldap_manual_config=false
-ldap_passwords_in_clear_ok=true
-ldap_tls=false
-ldap_uri=
I know the option values for some of them are the default ones, but I chose to add the options to the Safety Valve anyway for completeness.

Re: No available Impalad to send queries to

Expert Contributor
Oh, sorry, meant which ldap properties did you have set for Hue? Mainly, did you have:

[desktop]
ldap_username=
ldap_password=
Don't have an account?
Coming from Hortonworks? Activate your account here