Support Questions

Find answers, ask questions, and share your expertise

No available Impalad to send queries to

Contributor

We are running CDH 5.3.3 with Hue 3.7.0, and just added impala via Cloudera Manager. Whenever we log on to Hue, the "No available Impalad to send queries to." appears. Cloudera Manager doesn't report anything wrong with either impala or Hue. The impala and Hue logs don't show any errors. 

Any help would be greatly appreciated.

Thanks!

 

For completeness, I also want to add that the impala-shell works without a problem. The issue seems to be restricted to Hue.

1 ACCEPTED SOLUTION

Contributor

Problem solved. Rebooting the cluster servers didn’t fix the issue. The problem was due to Hue being configured with LDAP. Even though I didn’t find anything that says otherwise, I didn’t think that Having LDAP implemented for Hue required Impala too to be configured for LDAP. After doing that the misconfiguration message disappears, and everything works fine.

Thanks again for your help!

View solution in original post

29 REPLIES 29

Expert Contributor
Ahhh, that is why:-). Those properties:

[desktop]
ldap_username
ldap_password

Tell Hue to use ldap when authenticating against Impala and HS2. So if you're not using ldap for Impala and HS2, then you can remove those and you don't need ldap for Impala.

Contributor
Good to know, thanks! Hue is indeed using LDAP to authenticate against HS2. I think it would be helpful to have a message in the log to point admins in the right direction 🙂

Expert Contributor
Jira filed:-)

https://issues.cloudera.org/browse/HUE-2749

Right now Hue requires both Impala and HS2 to be configured for Ldap, so ldap_username and ldap_password are global. There is also a feature request out there to make those specific for Impala and HS2 so that would be less of an issue in the future.

+1 !



can you kindly tell me how to configure HS2 for LDAP. 

I have an environment in which Impala and Hue are LDAP configured but i dont know how to configure HS2 for LDAP. 

 

Thanks in advance. 

Hi again,
Thanks, Hue works with LDAP enabled Impala, but if i enable SSL on impala, Hue gives the same error again i.e. "No available Impalad to send queries to"
Is there a workaround for it ?
Thanks

You need to configure the [impala] section of Hue to use SSL, e.g.
http://gethue.com/how-to-use-hue-with-hive-and-impala-configured-with-ldap-authentication-and-ssl/

Rising Star

Hi,@MC,My Hue still can not work, can help me? Thank you!粘贴图片.png