Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Node1 Still appeared in the Host List after decommissioned it

Solved Go to solution
Highlighted

Node1 Still appeared in the Host List after decommissioned it

Hi Guys,
I have Follow all the step that were needed to decommission a node.
but after all steps :
1. Decommission the services
2. Delete Host from Cluster
3. Delete all packages that were installed.
but when i write the command :
"Cat /etc/Host"
that specific node "Node1" still appearing in the list ?
is that ok or i have missing something ?
NOTE : Particular Node "Node1" successfully removed from the list of Ambari Hosts.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Node1 Still appeared in the Host List after decommissioned it

@Mudassar Hussain,

Ambari does not manage /etc/hosts file. You should manually delete the entry from /etc/hosts file. If you want to see if the host is deleted or not , you can call Ambari REST api and check the response

curl -k -u {username}:{password} -H "X-Requested-By:ambari" http://{ambari-host}:{ambari-port}/api/v1/hosts

If the above call doesn't return the deleted host , then you can confirm that the host is deleted.

Thanks,

Aditya

View solution in original post

5 REPLIES 5
Highlighted

Re: Node1 Still appeared in the Host List after decommissioned it

@Mudassar Hussain,

Ambari does not manage /etc/hosts file. You should manually delete the entry from /etc/hosts file. If you want to see if the host is deleted or not , you can call Ambari REST api and check the response

curl -k -u {username}:{password} -H "X-Requested-By:ambari" http://{ambari-host}:{ambari-port}/api/v1/hosts

If the above call doesn't return the deleted host , then you can confirm that the host is deleted.

Thanks,

Aditya

View solution in original post

Highlighted

Re: Node1 Still appeared in the Host List after decommissioned it

Thanks @Aditya Sirna
it Works :-)

Highlighted

Re: Node1 Still appeared in the Host List after decommissioned it

@Mudassar Hussain,

Glad that it worked. Can you please close this thread my marking it as accepted. This will be really useful for the community.

Re: Node1 Still appeared in the Host List after decommissioned it

I have accept you answer but not know how to close the thread ?

Highlighted

Re: Node1 Still appeared in the Host List after decommissioned it

@Mudassar Hussain,

Accepting the answer will do it. Thanks :)

Don't have an account?
Coming from Hortonworks? Activate your account here