Support Questions

Find answers, ask questions, and share your expertise
Celebrating as our community reaches 100,000 members! Thank you!

Not able to access HDFS, getting Connection exception.

New Contributor

I started the Cloudera VM normally, But when I am doing a list on the files in HDFS, I am getting a Connection Exception as follows:


[cloudera@quickstart ~]$ hadoop fs -ls /user/
ls: Call From quickstart.cloudera/ to quickstart.cloudera:8020 failed on connection exception: Connection refused; For more details see:


I guess it is because of the Hadoop services not running but can somebody please suggest, when i am starting the CLoudera VM as required why getting this error?




All the basic Hadoop services should be running when you start the VM. Port 8020 is for the hadoop-hdfs-namenode service, so my guess is that service has failed and just needs to be restarted.


You can check the status of a service with

service <service-name> status

and you can restart a service with

service <service-name> restart

So 'service hadoop-hdfs-namenode restart' may be all you need. Also check the hadoop-hdfs-datanode service as it may also need to be restarted.


The services should have been running, so if they're not it means something went wrong. If you're curious or if you continue to have a problem, have a look at the NameNode logs in /var/log/hadoop-hdfs for anything that looks like a fatal error and post it back here.


New Contributor

My datanode service is running fine but yes the namenode servoce is not running.

I restarted it but the restart is getting failed:


[root@quickstart cloudera]# service hadoop-hdfs-datanode status
Hadoop datanode is running                                 [  OK  ]
[root@quickstart cloudera]# service hadoop-hdfs-namenode restart
no namenode to stop
Stopped Hadoop namenode:                                   [  OK  ]
starting namenode, logging to /var/log/hadoop-hdfs/hadoop-hdfs-namenode-quickstart.cloudera.out
Failed to start Hadoop namenode. Return value: 1           [FAILED]


Please advice.

New Contributor

I am facing the same issue. Please help me if u have found some soution to this. Please help 


did you resolve the issue I am facing the same issue when trying to execute a command even after starting the service and having the status say okay.


First please see the status of service using this command

sudo service hadoop-hdfs-<service_name> status;

ex- sudo service hadoop-hdfs-namenode status;

If status is stop , please try to start using below command

sudo service hadoop-hdfs-<service_name> start;

If it's running , first stop it and again restart this.

sudo service hadoop-hdfs-<service_name> stop;

sudo service hadoop-hdfs-<service_name> restart;


Hope it will work for you.

Thanks for the response this did not work for me unfortunately. This is what I tried.
First I checked the status it was not running then I started the service with
sudo service hadoop-hdfs-datanode start
Then tried hadoop fs -ls /
This gave me the same error as before. Do I need to also start a namenode or something but Im thinking I shouldnt because I am not in control of namenodes and on other coworkers computers it just works. Any suggestions are appreciated.

Hi thanks for the docs. I actually needed to boot it from the cloudera manager. I could not do it from the commandline must have something to do with my setup.

WARN org.apache.hadoop.hdfs.server.datanode.DataNode: Problem connecting to server:

From the above error it is clear that the external datanode is having trouble connecting to Namenode.

You can do one thing. 


Check the status of the namenode you are connect by

Sudo Service hadoop-hdfs-namenode status
Sudo Service hadoop-hdfs-secondarynamenode status

if it has not started then you may start it by replacing the status with start if you dont have authorization you should contact the hadoop admin . Also please check the same for Secondarynamenode.