Support Questions

Find answers, ask questions, and share your expertise

Not able to install agents when trying to add a host in an existing cluster

New Contributor
3 REPLIES 3

@backlashhardik I am wondering if this is due to RHEL version difference. Since you are trying to add 6.9 hosts and CM is running on RHEL 7. 

Have to tried to install agent manually on host and then add it to CM? 


Cheers!
Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.

New Contributor

 

Hey, @GangWar thanks for your input.

As I tried to install the agent manually it says it's already installed.

Following the below link: https://docs.cloudera.com/documentation/enterprise/latest/topics/install_cloudera_packages.html

It has the following command which I ran:

sudo yum install cloudera-manager-agent cloudera-manager-daemons

The above gave me:

Loaded plugins: fastestmirror
Setting up Install Process
Loading mirror speeds from cached hostfile
Package cloudera-manager-agent-6.3.0-2117683.el6.x86_64 already installed and latest version
Package cloudera-manager-daemons-6.3.0-2117683.el6.x86_64 already installed and latest version
Nothing to do

 

Then I tried to add the host using Cloudera manager, it didn't work

No, manual installation did not work either.

@backlashhardik  The manual process means install agent beforehand on all of the hosts which you are going to add. Make sure you have local repo or internet access. 

 

sudo yum install cloudera-manager-agent cloudera-manager-daemons

 If agent is installed then reinstall to avoid any issue once again. 

sudo yum reinstall cloudera-manager-agent cloudera-manager-daemons

 Then you have to modify the /etc/cloudera-scm-agent/config.ini file and post this to CM server, also if TLS is enabled make necessary changes. 

[General]
# Hostname of the CM server.
server_host=host-xx.xxx.xxx.cloudera.com

Then go to the CM and try to add hosts from there. Since agent is already installed this should not take much time and you can start agent then and see if that helps. 


Cheers!
Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.
Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.