Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 12-14-2022 08:39 AM
Hello Team,
We recently upgraded from CDP 7.1.6 to CR 7.1.8. After the upgrade, we are having issues with starting the HDFS NFS Gateway role.
Earlier, on CDP 7.1.6, we would run the command - hdfs --daemon start portmap and then start the HDFS NFS Gateway role from the Cloudera Manager, however after the upgrade this is not working (that is the HDFS NFS Gateway role doesn't start after running the above command and starting the role from the Cloudera Manager). We are getting the following issue
Due to some security issues, we are not able to start rpcbind service. Is there a workaround to start the NFS Gateway? Note, the mount service does not start when even though the portmap service looks to have a running process.
Best Regards
Sayed Anisul Hoque
Created 11-15-2024 01:50 AM
HI Team, you can check the mount using below:
showmount -e <NFS servername>
Although as per the error it OS issue you should be checking with your internal team
Created 12-10-2024 09:17 PM
@Sayed016, Did the response assist in resolving your query? If it did, kindly mark the relevant reply as the solution, as it will aid others in locating the answer more easily in the future.
Regards,
Vidya Sargur,Created 12-11-2024 01:16 AM
@VidyaSargur it somewhat helped. It was failing because we had an NFS client running on that server. Since we have a customer-facing client -> server architecture for NFS, we could not start the HDFS NFS Gateway again on the same port. So, the only solution was to stop the HDFS NFS Gateway.