Support Questions

Find answers, ask questions, and share your expertise
Celebrating as our community reaches 100,000 members! Thank you!

NullPointerException when executing script in cluster




NiFi Version: 1.13.2


I am executing a python script within the Execute Script processor running on all nodes.

Sometimes it runs all right, but sometimes it gets stuck and do not get flowfiles from the queue, throwing a NullPointerException. As far as I understood, it creates conflicts with the flowfiles resulting in a few files pending in the queue without the possibility to empty it.


When right-clicking the queue (with a few hundred flowfiles in there) and selecting "Empty Queue", I just get the message ("X out of Y flowfiles removed"; where Y > X), or "No flowfiles removed" if attempting for a second time.


Then, after few minutes, one cluster node crashes.

The node error is the following:


07/14/2022 17:41:46 CEST: Node Status changed from CONNECTING to DISCONNECTED due to Proposed configuration is not inheritable by the flow controller because of flow differences: Found difference in Flows: Local Fingerprint: e48-a975-21705dd65dfa0e0aca15-0c1c-3c8a-9752-179b7491e6a273ebc2c5-31cb-37df-8dcf-5b955bce3d21FUNNELff90c485-cfc9-3b28-9113-f543ed94606b73ebc2c5-31cb-37df-8dcf-5b955bce3d21PROCESSORNO_VALUEDO_NOT_LOAD_ Cluster Fingerprint: e48-a975-21705dd65dfa0e0aca15-0c1c-3c8a-9752-179b7491e6a273ebc2c5-31cb-37df-8dcf-5b955bce3d21FUNNELf379500b-ae38-1ee5-0000-000021eee75273ebc2c5-31cb-37df-8dcf-5b955bce3d21PROCESSORNO_VALUEDO_NOT_LOAD_



I tried offloading the node and reconnecting it but it didn't work and the same error as above persists.


Is this some known issue? When running a script accross all nodes causes flowfile conflicts?

(I still didn't test running the same load through this processor with the "primary node" execution option - need to wait all nodes to be back up again)

The python script I'm running is here on github.


Thanks a lot in advance,