Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Oozie Error

Oozie Error

New Contributor

Hi ,  Am using CDH5.8.3  ,

I have started oozie service from cloudera manager . While submiting workflow  and running any of oozie admin commands  , am getting the following error ,

 

Error: IO_ERROR : java.io.IOException: Error while connecting Oozie server. No of retries = 1. Exception = Could not authenticate, Authentication failed, status: 302, message: Found

 

proxyuser host and group are '*' by default . Still issue is there. 

8 REPLIES 8
Highlighted

Re: Oozie Error

Guru

Hi,

 

I believe that those errors were from client output, can you also paste the error from the Oozie server log? Do you have Kerberos enabled? Did you mean that all Oozie commands fail with the same error?

Re: Oozie Error

New Contributor

Kerberos is not enabled. All oozie commands fails with this error . Logs have only the following entries ,


2017-01-02 13:05:54,632 INFO org.apache.oozie.service.PauseTransitService: SERVER[server] USER[-] GROUP[-] TOKEN[-] APP[-] JOB[-] ACTION[-] Acquired lock for [org.apache.oozie.service.PauseTransitService]
2017-01-02 13:05:54,639 INFO org.apache.oozie.service.PauseTransitService: SERVER[server] USER[-] GROUP[-] TOKEN[-] APP[-] JOB[-] ACTION[-] Released lock for [org.apache.oozie.service.PauseTransitService]
2017-01-02 13:06:39,624 INFO org.apache.oozie.service.StatusTransitService$StatusTransitRunnable: SERVER[server] USER[-] GROUP[-] TOKEN[-] APP[-] JOB[-] ACTION[-] Acquired lock for [org.apache.oozie.service.StatusTransitService]
2017-01-02 13:06:39,625 INFO org.apache.oozie.service.StatusTransitService$StatusTransitRunnable: SERVER[server] USER[-] GROUP[-] TOKEN[-] APP[-] JOB[-] ACTION[-] Running coordinator status service from last instance time = 2017-01-02T12:05Z
2017-01-02 13:06:39,627 INFO org.apache.oozie.service.StatusTransitService$StatusTransitRunnable: SERVER[server] USER[-] GROUP[-] TOKEN[-] APP[-] JOB[-] ACTION[-] Running bundle status service from last instance

Re: Oozie Error

Contributor

Hi,

 

     did you find solution for the above problem?

 

 

Thanks & Regards,

J.Ganesh Kumar.

Re: Oozie Error

New Contributor

Hi,

 

We have the same issue here:

[user@server tmp]$ klist
Ticket cache: FILE:/tmp/krb5cc_1221406138_rBzFRx
Default principal: user@CORP.SOMECORP.HU

Valid starting Expires Service principal
04/06/2018 09:01:20 04/06/2018 19:01:20 krbtgt/CORP.SOMECORP.HU@CORP.SOMECORP.HU
renew until 04/07/2018 09:01:20
[user@server tmp]$ oozie admin -oozie http://localhost:11001/oozie -status
Connection exception has occurred [ java.net.SocketException Connection reset ]. Trying after 1 sec. Retry count = 1
Connection exception has occurred [ java.net.SocketException Connection reset ]. Trying after 2 sec. Retry count = 2
^C[user@server tmp]oozie admin -oozie http://localhost:11000/oozie -status
Error: IO_ERROR : java.io.IOException: Error while connecting Oozie server. No of retries = 1. Exception = Could not authenticate, Authentication failed, URL: http://localhost:11000/oozie/versions?server.name=user, status: 302, message: Found

 

We would really appreciate some insight on this! Thank you

Re: Oozie Error

Guru
Hi,

You used the wrong Oozie URL, once the cluster is kerberized, you need to use the Oozie URL that matches with the kerberos principal. So please update the URL from :

http://localhost:11000/oozie

To:

http://<oozie-url>:11000/oozie

Let me know if that helps.

Re: Oozie Error

New Contributor

Hi,

 

Please check if you are running the command from nodes running oozie server. Please go to yarn->oozie->instances and check if the servers listed there are the ones from which you are submitting the oozie job.

 

I had also had the same error and this is what i did. 

 

Thanks,

Mahesh.

Re: Oozie Error

Explorer

Hi Mahesh,

 

Am running Oozie admin command from oozie server and i have used oozie url which is as in the Kerberose principal. But still am getting connection refused error.

 

Thanks

 

Siva

Re: Oozie Error

Contributor

Hello sparamas,

 

                 Below are the steps are must follow when submitting the oozie job from oozie server.

 

  1. Kinit with principle and keytab [ kinit user_principle -k -t key_tab ]
  2. must use fqdn along with oozie server name in command 
    oozie job -oozie http://machine_name@domain:11000/oozie -config xxxx -run
Don't have an account?
Coming from Hortonworks? Activate your account here