Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

Oozie FNF: Required Local file base.sh not present

avatar
Explorer

Hi, I'm struggling with the error below while trying to run Oozie workflow containing ssh action:

[FNF], Message [FNF: Required Local file /tmp/oozie-oozi2214367252678167938.dir/ssh/ssh-base.sh not present

 

Can anyone please suggest a potential cause and resolution? 

 

Thank you!

1 ACCEPTED SOLUTION

avatar
Contributor

@ST1

I reckon it is one knonw issue. Oozie will store temp files in /tmp dir. If /tmp dir has been cleaned up , you may hit this error.

As workaround,we can change the tmpdir to different dir and restart the Oozie to make it work.

  1. Go to Cloudera Manager > Oozie > Configuration > Java Configuration Options for Oozie Server
  2. Append the following, replacing "/new/directory" with the new path to use:
    -Djava.io.tmpdir=/new/directory

View solution in original post

4 REPLIES 4

avatar
Community Manager

@ST1 Welcome to the Cloudera Community!

To help you get the best possible solution, I have tagged our Ozzie experts @jAnshula @DennisTong  who may be able to assist you further.

Please keep us updated on your post, and we hope you find a satisfactory solution to your query.


Regards,

Diana Torres,
Senior Community Moderator


Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.
Learn more about the Cloudera Community:

avatar
Contributor

@ST1

I reckon it is one knonw issue. Oozie will store temp files in /tmp dir. If /tmp dir has been cleaned up , you may hit this error.

As workaround,we can change the tmpdir to different dir and restart the Oozie to make it work.

  1. Go to Cloudera Manager > Oozie > Configuration > Java Configuration Options for Oozie Server
  2. Append the following, replacing "/new/directory" with the new path to use:
    -Djava.io.tmpdir=/new/directory

avatar
Explorer

@DennisTong 

That\s brilliant, thank you for jumping in so quickly. I am yet to test this (need to have a word with our admins) but I can't tell you how much I appreciate the info. I'll come back with an update as soon as I have it.

@DianaTorresthank you as well for looping in Dennis.

avatar
Explorer

@DennisTong : this did the trick, can't thank you enough!