Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 02-02-2024 01:56 PM
Hi, I'm struggling with the error below while trying to run Oozie workflow containing ssh action:
[FNF], Message [FNF: Required Local file /tmp/oozie-oozi2214367252678167938.dir/ssh/ssh-base.sh not present
Can anyone please suggest a potential cause and resolution?
Thank you!
Created 02-02-2024 11:26 PM
I reckon it is one knonw issue. Oozie will store temp files in /tmp dir. If /tmp dir has been cleaned up , you may hit this error.
As workaround,we can change the tmpdir to different dir and restart the Oozie to make it work.
-Djava.io.tmpdir=/new/directory
Created 02-02-2024 09:14 PM
@ST1 Welcome to the Cloudera Community!
To help you get the best possible solution, I have tagged our Ozzie experts @jAnshula @DennisTong who may be able to assist you further.
Please keep us updated on your post, and we hope you find a satisfactory solution to your query.
Regards,
Diana Torres,Created 02-02-2024 11:26 PM
I reckon it is one knonw issue. Oozie will store temp files in /tmp dir. If /tmp dir has been cleaned up , you may hit this error.
As workaround,we can change the tmpdir to different dir and restart the Oozie to make it work.
-Djava.io.tmpdir=/new/directory
Created 02-03-2024 10:06 AM
That\s brilliant, thank you for jumping in so quickly. I am yet to test this (need to have a word with our admins) but I can't tell you how much I appreciate the info. I'll come back with an update as soon as I have it.
@DianaTorresthank you as well for looping in Dennis.
Created 02-05-2024 10:38 PM
@DennisTong : this did the trick, can't thank you enough!