Support Questions
Find answers, ask questions, and share your expertise

Oozie error after upgrade

Explorer

Hello,

We have upgraded our cluster and are getting error " The Oozie Server build version(4.1.0-cdh5.16.2) and the Oozie Server shared library version(4.1.0-cdh5.14.2) do not match". We have done the following:

Upgrade the Oozie SharedLib
Go to the Oozie service
If the Oozie service is stopped, start it:
Select Actions > Start and click Start to confirm.
Select Actions > Install Oozie SharedLib and click Install Oozie SharedLib to confirm.

 

The service became Green from some time and then again its Red, kindly suggest / guide path to fix this

 

 

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Oozie error after upgrade

Guru
Please use commands mentioned here:
https://oozie.apache.org/docs/4.3.0/DG_CommandLineTool.html#Getting_list_of_available_sharelib

to check if your sharedlib was installed correctly.

Cheers
Eric

View solution in original post

3 REPLIES 3

Re: Oozie error after upgrade

Guru
Please use commands mentioned here:
https://oozie.apache.org/docs/4.3.0/DG_CommandLineTool.html#Getting_list_of_available_sharelib

to check if your sharedlib was installed correctly.

Cheers
Eric

View solution in original post

Re: Oozie error after upgrade

Explorer

Hi EricL,

 

Thanks for your help.

Re: Oozie error after upgrade

Guru
Glad it helps.

Cheers
Eric