Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Oozie shell action - sqoop cant find hive-site.xml from shell script

Solved Go to solution

Oozie shell action - sqoop cant find hive-site.xml from shell script

Explorer

 

Sqoop called a script invoked by a shell action keeps defaulting to derby metastore even though mysql is configured in hive-site-xml.  I've tried a number of ways to specify the location of hive-site.xml but am missing the secret sauce.   Hive-site.xml is in the workflow directory on hdfs co-located with the script.

 

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Oozie shell action - sqoop cant find hive-site.xml from shell script

Expert Contributor
There are 2 options here:

1. If using CM, put a Hive gateway on every NodeManager/TaskTracker in the cluster, if not using CM, put the hive-site.xml in /etc/hive/conf on every NodeManager/TaskTracker.
2. Add "export HIVE_CONF_DIR=`pwd`" to the top of your shell script and then sqoop shoudl check the local directory for the hive-site.xml.
2 REPLIES 2
Highlighted

Re: Oozie shell action - sqoop cant find hive-site.xml from shell script

Expert Contributor
There are 2 options here:

1. If using CM, put a Hive gateway on every NodeManager/TaskTracker in the cluster, if not using CM, put the hive-site.xml in /etc/hive/conf on every NodeManager/TaskTracker.
2. Add "export HIVE_CONF_DIR=`pwd`" to the top of your shell script and then sqoop shoudl check the local directory for the hive-site.xml.

Re: Oozie shell action - sqoop cant find hive-site.xml from shell script

Explorer

 

I ended up going with option 2 which solved the immediate problem.  Thanks.

Don't have an account?
Coming from Hortonworks? Activate your account here