Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

Parquet schema error

avatar
Contributor

I had a table that it vanished after an issue. I created again the table and then recover the partitions in order to read again the files that were in hdfs hive direcotry. Although all of a sudden now, it throws me the below error:

 

File 'path/data.0.parq' has an incompatible Parquet schema for column 'db.table.parameter_11'. Column type: STRING, Parquet schema: optional int64 amount [i:10 d:1 r:0]

 

 

1 ACCEPTED SOLUTION

avatar
Expert Contributor

Hi,

 

can you use beeline and type the below command then recreate the table :

 

set parquet.column.index.access=false; 

this should make hive not use the index of your create table statement to map the data in your files, but instead it will use the columns names .

hope this works for you.

 

Best Regards  

View solution in original post

1 REPLY 1

avatar
Expert Contributor

Hi,

 

can you use beeline and type the below command then recreate the table :

 

set parquet.column.index.access=false; 

this should make hive not use the index of your create table statement to map the data in your files, but instead it will use the columns names .

hope this works for you.

 

Best Regards