Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Problem in Installing HCP 1.7.1 using Ambari

Solved Go to solution

Problem in Installing HCP 1.7.1 using Ambari

New Contributor

I try to install HCP 1.7.1 with ambari in centos 7 ( single node ) but metron and elasticsearch don't exist in available services for installation . what is problem ?!

94512-7530.png

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Problem in Installing HCP 1.7.1 using Ambari

Super Collaborator

@haco fayik, HCP is not supported on Ambari 2.7. You need to use Ambari 2.6.2.

Further, please use this URL to check for the supported OS', Ambari, HDP and other requisites:

https://supportmatrix.hortonworks.com/

9 REPLIES 9

Re: Problem in Installing HCP 1.7.1 using Ambari

Hi @haco fayik,

Have you installed the HCP 1.7.1 mpack in ambabari following the steps : https://docs.hortonworks.com/HDPDocuments/HCP1/HCP-1.7.1/ambari-install/content/installing_hcp_ambar...

if you are intalling HCP via ambari, please carefully follow each steps mentioned in : https://docs.hortonworks.com/HDPDocuments/HCP1/HCP-1.7.1/ambari-install/content/installing_hcp_on_an...

Re: Problem in Installing HCP 1.7.1 using Ambari

New Contributor

hi @Akhil S Naik,

thanks for you answer

I installed mpack in ambari . is it possible to run HCP on single node ?!

Re: Problem in Installing HCP 1.7.1 using Ambari

Hi @haco fayik,

I didn't understand whether you are able to resolve the issue from your previous answer(please accept the anwser if it did). if it doesn't can you see if your mpack of HCP is listed in

cd /var/lib/ambari-server/resources/mpacks<br>ls -l

and revert if it still has the HCP mpack and you have restarted ambari-server.

for your second question about single node , you can refer the Memory requirements and OS Requirements here : https://docs.hortonworks.com/HDPDocuments/HCP1/HCP-1.7.1/prepare-to-install/content/infrastructure_r...

https://docs.hortonworks.com/HDPDocuments/HCP1/HCP-1.7.1/prepare-to-install/content/preparing_to_ins...

Re: Problem in Installing HCP 1.7.1 using Ambari

New Contributor

thanks @Akhil S Naik

I get below result after executing "ls -l" command :

  1. [root@node11 mpacks]# ls -l
  2. total 4
  3. drwxr-xr-x.2 root root 93Dec1105:57 cache
  4. drwxr-xr-x.4 root root 69Dec1105:57 elasticsearch-ambari.mpack-5.6.2
  5. drwxr-xr-x.4 root root 69Dec1105:54 metron-ambari.mpack-0.6.1.0
  6. -rwxr-xr-x.1 root root 451Dec1105:57 mpacks_replay.log

and after restarting ambari-server nothing change .

What else can I do?

Re: Problem in Installing HCP 1.7.1 using Ambari

New Contributor

I get below result after executing "ls -l" command :

[root@node11 mpacks]# ls -l
total 4
drwxr-xr-x. 2 root root  93 Dec 11 05:57 cache
drwxr-xr-x. 4 root root  69 Dec 11 05:57 elasticsearch-ambari.mpack-5.6.2
drwxr-xr-x. 4 root root  69 Dec 11 05:54 metron-ambari.mpack-0.6.1.0
-rwxr-xr-x. 1 root root 451 Dec 11 05:57 mpacks_replay.log

and after restarting ambari-server nothing change .

What else can I do?

Re: Problem in Installing HCP 1.7.1 using Ambari

New Contributor

Please help

Re: Problem in Installing HCP 1.7.1 using Ambari

Super Collaborator

@haco fayik, HCP is not supported on Ambari 2.7. You need to use Ambari 2.6.2.

Further, please use this URL to check for the supported OS', Ambari, HDP and other requisites:

https://supportmatrix.hortonworks.com/

Re: Problem in Installing HCP 1.7.1 using Ambari

New Contributor

Thanks bro

Re: Problem in Installing HCP 1.7.1 using Ambari

New Contributor

thanks @asubramanian