Support Questions

Find answers, ask questions, and share your expertise

Problem uploading a 1.4MB template to Nifi

New Contributor

Hi, I am running NiFi 0.8.x. I am failing to upload a large (1.4MB) template to NiFi. The error shown is "entity too large". I have NiFi sitting behind Nginx and I have configured Nginx with client_max_body_size 2M. So I don't think that is the problem. I am guessing that Jetty has its org.eclipse.jetty.server.Request.maxFormContentSize set too low (I believe the default is 200K - See htttps://wiki.eclipse.org/Jetty/Howto/Configure_Form_Size). Is there a NiFi setting to control this or some other way to override the Jetty setting?

Thanks!

3 REPLIES 3

New Contributor

I tried adding -Dorg.eclipse.jetty.server.Request.maxFormContentSize=2000000 by modifying bootstrap.conf, but the problem persists.

Hello there Chris. While not a direct answer to your question the community made the NiFi 1.x release line available in Aug 2016. In the latest release on the 1.x line (1.5.0) the community introduced the Apache NiFi Registry. This provides a really powerful and well integrated way to have versioned flows stored in a central registry which you can use to have good SDLC behaviors from dev, to staging, to prod and which handles things like sensitive properties and processor group level variables well. It also lets you have nested versioned groups which is really useful for multi-tenant/team cases.

New Contributor

For the record I ran into this problem again and stumbled upon my own question. It turns out that the limit was be imposed by the NGINX we had in front of NiFi and not by NiFi itself.