Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Problems upgrading HDF from 2.6.4.0 -> 3.1.1.0

Solved Go to solution
Highlighted

Problems upgrading HDF from 2.6.4.0 -> 3.1.1.0

New Contributor

After registering the 3.1.1.0 version, when I choose to install this version on my cluster, Ambari brings me back to the Stacks and Version page with no 3.1.1.0 stack available to upgrade. I tried going from 2.6.4.0 to 3.0.2.0 with the same results. Is there something I need to do to go from 2.6.4.0 to 3.1.1.0?

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Problems upgrading HDF from 2.6.4.0 -> 3.1.1.0

@Jeremy Hansen

Are you talking about HDP 2.6.4.0? There is no HDF 2.6.4.0. Assuming that you had an existent HDP 2.6.4.0 cluster and you wish to use the same instance of Ambari to install HDF 3.1.1.0 services, you need to install first the management pack for HDF 3.1.1.0. Here are the steps in the documentation: https://docs.hortonworks.com/HDPDocuments/HDF3/HDF-3.1.1/bk_installing-hdf-on-hdp/content/upgrading_...

Validate that you followed the steps appropriately.

Be aware that you will be able to install only NiFi and NiFi Registry. All other services cannot be installed with Ambari 2.6.1.3 and current HDF 3.1.1.1. You would have to wait until HDF 3.2 to be able to add all other services from HDF 3.2 stack using the same Ambari instance for HDP and HDF.

If this response helped, please vote and accept the response.

3 REPLIES 3

Re: Problems upgrading HDF from 2.6.4.0 -> 3.1.1.0

@Jeremy Hansen

Are you talking about HDP 2.6.4.0? There is no HDF 2.6.4.0. Assuming that you had an existent HDP 2.6.4.0 cluster and you wish to use the same instance of Ambari to install HDF 3.1.1.0 services, you need to install first the management pack for HDF 3.1.1.0. Here are the steps in the documentation: https://docs.hortonworks.com/HDPDocuments/HDF3/HDF-3.1.1/bk_installing-hdf-on-hdp/content/upgrading_...

Validate that you followed the steps appropriately.

Be aware that you will be able to install only NiFi and NiFi Registry. All other services cannot be installed with Ambari 2.6.1.3 and current HDF 3.1.1.1. You would have to wait until HDF 3.2 to be able to add all other services from HDF 3.2 stack using the same Ambari instance for HDP and HDF.

If this response helped, please vote and accept the response.

Re: Problems upgrading HDF from 2.6.4.0 -> 3.1.1.0

New Contributor

I just realized I had a HDP stack installed from the beginning. During install, I must have mistakenly chose HDP instead of HDF. Since this is a dev cluster, I just did a "ambari-server reset" and restarted over making sure I chose HDF. Thank you!

Re: Problems upgrading HDF from 2.6.4.0 -> 3.1.1.0

New Contributor

@Jeremy Hansen

Happy that you got a new shot at it :) If the response was helpful, please vote and accept @Constantin Stanca response

Don't have an account?
Coming from Hortonworks? Activate your account here