Support Questions
Find answers, ask questions, and share your expertise

Problems with views

Explorer

I have the HDP 2.6 sandbox installed. As I am going through the tutorial, I can not get anything to display in the Files view. I have tried this for both the admin and maria_dev accounts. When I try to open the Hive View 2.0, it runs through the checks and give me a "Cannot open a hive connection with connect string" error. I'd love to be able to make it through the tutorial so I can adequately evaluate Hortonworks, but I'm struggling with issues like these that don't seem to be documented and questions asked previously in this community for related issues don't seem to have been answered. Or at least the answers provided do not seem to resolve my issues.

12 REPLIES 12

Guru

Hi @Larry Wilson

The connect string that Hive View 2.0 is using looks ok, however, the Hive View logs show an underlying error: ava.sql.SQLException: org.apache.hive.jdbc.ZooKeeperHiveClientException: Unable to read HiveServer2 configs from ZooKeeper

Do you have HiveServerHA enabled?

I would start by starting/stopping ZooKeeper, then starting/stopping Hive all from Ambari and trying again. Can you do this and report back results.

View solution in original post

Explorer

Well, it turns out that neither the ZooKeeper nor the Hive services were running. I started them and the Hive error went away. However, after restarting those services, I was still getting the a failure on the ATS check. Starting the YARN service resolved this. Thanks, Sonu.

Mentor

@Larry Wilson

Could this be the link you are looking for ?