Support Questions
Find answers, ask questions, and share your expertise

Protected multilib versions: libcom_err

New Contributor

Hi,

 

I am trying to install on my local Centos VM and I am getting the below error.

Trying it through Cloudera Manager. 

 

Protected multilib versions: libcom_err-1.41.12-23.el6.i686 != libcom_err-1.42.8-1.0.1.el6.x86_64 
remote package cloudera-manager-agent could not be installed, giving up 
waiting for rollback request 

 

This happens when the install command is run:

yum -y install cloudera-manager-agent 

 

Below are the versions of this library currently installed.

 

[root@psvlxprof2 ~]# yum list | grep libcom_err
libcom_err.x86_64 1.42.8-1.0.1.el6 @ol6_latest
libcom_err.i686 1.41.12-23.el6 base
libcom_err-devel.i686 1.41.12-23.el6 base
libcom_err-devel.x86_64 1.41.12-23.el6 base
[root@psvlxprof2 ~]#

 

I tried to uninstlal these, but they have YUM dependencies. When I tried to unstall using rpm, it locked me out of the box.

 

I tried to verify dependencies, but only os level is listed as a dependency.

Below is the version of my VM.

 

[root@psvlxprof2 ~]# cat /etc/redhat-release
CentOS release 6.9 (Final)
[root@psvlxprof2 ~]#

 

I tried to go to an older version like 5.10 using the Cloudera Managre and got the same error.

There are otherwise no issues with Yum.

 

Please assist. 

1 ACCEPTED SOLUTION

New Contributor

Fixed the problem. I had two conflicting repos setup. One was centos and one was oracle linux.

Ran the below commands to resolve the issue.

 

yum-config-manager --disable ol6_latest
yum-config-manager --disable ol6_UEK_latest

 

yum clean all
yum distro-sync
yum update

 

Thanks

View solution in original post

1 REPLY 1

New Contributor

Fixed the problem. I had two conflicting repos setup. One was centos and one was oracle linux.

Ran the below commands to resolve the issue.

 

yum-config-manager --disable ol6_latest
yum-config-manager --disable ol6_UEK_latest

 

yum clean all
yum distro-sync
yum update

 

Thanks

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.