Support Questions

Find answers, ask questions, and share your expertise
Celebrating as our community reaches 100,000 members! Thank you!

PutSQL doesn't work properly


Hello all,

I have a weird issue with this processor, PutSQL, precisely, I am trying to execute a SQL insert script but doesn't work, meaning, is only stay in running mode without doing nothing. In the logs I do not have any errors or warning messages.

The connections to the DB are correct, verified with our DBA, even more, the DBA said that there are not any sessions open. I am saying that this is weird because before is was working with the same workflow. Also, there was no other modifications or applied patches at DB level which can stop this processor to insert data. Moreover, ExecuteSQL is working, I can extract data from the tables. Also the schema/user has all the privileges needed for this task and the tables are well created, some don't have even primary key in order to avoid some other issues which maybe Nifi didn't show them.

Also, the ReplaceText provide a perfect script, I copy it and execute it via Toad and SQL Dev and the line is inserted.

I am using locally Nifi 1.4.0 but also I tried with Nifi 1.5.0 and is the same behavior. I tried also from other colleague computer and is the same.
Any advise would be great. Thank you !

Kind regards,


Master Collaborator

@Stefan Constantin

Hi, I had the same problem with PutSQL. Changing the processors property "Support Fragmented Transactions" to "false" solved it apparently.

Additionaly I set the property "Max Total Connections" of the Controller Service of the DBCPConnection to "-1" (=> max. number of active connections at the same time = no limit).

Using NiFi 1.6.0