Support Questions

Find answers, ask questions, and share your expertise
Announcements
Celebrating as our community reaches 100,000 members! Thank you!

Ranger audit problem accessing /solr/ranger_audits/select. Reason: Not Found.

avatar
Contributor

Hi,

this is a HDP 2.6.2.14-5 deployment using Ambari 2.5.2 with enabled Kerberos.

I've successfully installed Ambari-Infra service and, after installing Ranger, the access audit is showing this error:

HTTP ERROR 404

Problem accessing /solr/ranger_audits/select. Reason:

Not found

This is the configuration in ranger.audit.solr.urls:

http://<fqdn>:8886/solr/ranger_audits

Many thanks in advance,

Jorge.

1 ACCEPTED SOLUTION

avatar
Contributor
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login
7 REPLIES 7

avatar

Jorge Florencio is this Error you are seeing coming while accessing the audits from ranger UI ?

avatar
Contributor

Hi Deepak,

now it's working, after enabling SolrCloud.

Thank you,

Jorge.

avatar
Rising Star

A few days ago, I have suffered from exactly same issue. ZK, Solr, Ranger all restarted but there is no collection. Anybody knows the solution?

avatar
Contributor
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login

avatar
Rising Star

SolrCloud already enabled. Sometimes rager_audit collection created, but not for me.

avatar
Explorer

+1 on enabling SolrCloud. (Ambari -> Ranger -> Configs -> Ranger Audit -> Audit to SolrCloud: ON)

avatar
New Contributor

Works for me.

 

+1 on enabling SolrCloud. (Ambari -> Ranger -> Configs -> Ranger Audit -> Audit to SolrCloud: ON)