Support Questions

Find answers, ask questions, and share your expertise
Celebrating as our community reaches 100,000 members! Thank you!

Registered version HDP- is not listed


I'm going to update HDP- to HDP- using Ambari.

After I've registered HDP- version, it's not displayed on Versions tab in Ambari.

I'm using Ambari 2.2. What am I missing?


New Contributor

@ Dennis Fridlyand


I had the same problem and I have tried this and it works!

1 - Access Ambari Database

2 - ambari=> select * from stack;

stack_id | stack_name | stack_version


1 | HDP | 2.3

2 | HDP | 2.1.GlusterFS

3 | HDP | 2.2

4 | HDP | 2.1

5 | HDP | 2.0

6 | HDP | 2.0.6

7 | HDP | 2.3.GlusterFS

8 | HDP | 2.0.6.GlusterFS

ambari=> select cluster_id, desired_stack_id from clusters;

cluster_id | desired_stack_id


4 | 3

Then update table "clusters" to set the correct stack_id (HDP 2.3)

ambari=> update clusters set desired_stack_id = 1 where cluster_id = 4;

View solution in original post


Master Guru

@Dzianis Frydliand

Maybe the URLs you registered are not accessible. I had the same issue the other day and there was no error, only the version was not registered. Just retry to register the new version again, making sure the repo URLs are correct and accessible.


@Predrag Minovic

I've created a local copy of HDP-2.3.4 repo on my network and it's accesible by all nodes.

I did the same when updted 2.2.0 to 2.2.8 and 2.2.9 and it worked fine for me. The issue is only while trying to upgrade 2.2.* to 2.3.*

Master Guru

I understand what are you saying, but it's possible that your "Base URLs" don't map exactly your un-tarred directory layout. If you are using the latest HDP-UTILS the layout of directories after untar is a little bit different than before. So, can you please check that. Also check ambari-server log if the registration fails again. Finally, if you are most certain that your Base URLs are correct you can check "Skip repo base URL validation" flag at the bottom of the page, but it's not recommended.

Master Guru

By the way, to check your base URLs you can try this, from any node in the cluster:

wget <HDP-base-URL>/repodata/repomd.xml 
wget <HDP-UTILS-base-URL>/repodata/repomd.xml


Dear @Predrag Minovic,

Thank you for your answer.

I've made all of the suggested checks, but no result... The version HDP- is registered and listed on 'Manage Versions' page (pls, see the attached picture).


When I click on the 'Install on...' button for version HDP-, I'm transferred back to 'Stack and Versions' page, and I don't see previously registered version HDP-


Master Guru

Hi @Dennis Fridlyand, well at this point I don't have any other idea. Anything in your abmari-server.log? The other day I registered, installed and upgraded from 2.2.8 to 2.3.4, the only difference with your screenshot was that I didn't have 2.2.9 ready to perform upgrade. Though, that page implies that you can register and install multiple versions. Is an upgrade to 2.2.9 first and then to 2.3.4 an option? Re repos: public or local should not make any difference as far as the links are accessible and correct. I always use local because the install is much faster.

Master Mentor

@Dennis Fridlyand

why don't upgrade to first, the current 2.2.8 will be de-registered and try again then? Also consider trying Ambari that was just released. I'm guessing but I think Ambari can only maintain 4 versions of HDP and you have all four, you might need to drop one before upgrading to 2.3.4. Wierder things have happened...


@Artem Ervits

I'll try to use ambari

It seems to me that I'm facing issue