Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Remove qualifier from column name

Remove qualifier from column name

New Contributor

Hi All,

We have an SSIS package which is consuming data from an ODBC connection based on the Hortonworks Hive driver. We have noticed that when we use the DSN connection from our production environment the package works fine, but when calling it from an other environment it is changing the query result set. More specifically it is adding the table qualifier to the columns. We have set both ODBC connections with the same configuration, but we're still facing this issue in our lower environments. Example:On production we get "column" while on QA we get "table.column".

Could this be an issue with the default driver settings? We're using v2.1.5.1006 on Production and v2.1.6.1023 on QA.

Or is there an ODBC setting to remove the qualifier from being added to the column name?

Thanks for your assistance.

5 REPLIES 5

Re: Remove qualifier from column name

Super Collaborator

Are you running the same query from both clients, connected to the same server (HIVE)? Dependent on the SQL you are running a table name in front of a column name can be required, so in case of different queries that might be the reason.

Re: Remove qualifier from column name

New Contributor

Ryan, Set the below property to false to avoid table name as prefix.

set hive.resultset.use.unique.column.names=false;

Re: Remove qualifier from column name

New Contributor

@Herald, the only thing being modified is the ODBC connection. Basically on QA we have the same configuration (host, schema, and authentication) as we have on Production. The only thing which is different is the driver version. The SSIS package is built in such a way as to minimize user manipulation and only the connection strings can be modified.

@Avinash, do I need to set hive.resultset.use.unique.column.names=false; on the ODBC configuration? Or it's a configuration on the Hive server?

Re: Remove qualifier from column name

New Contributor

It's a configuration on hive server.

Re: Remove qualifier from column name

New Contributor

@Avinash thanks for your reply.

This was solved by using the same driver as we had on Production.