Support Questions

Find answers, ask questions, and share your expertise

ResourceManager YARN cannot started

Hi I am using the Sandbox 2.3.2

I just download it 2 weeks ago.

At the first week before I am running with 4 GB RAM. Then i request it to my team to upgrade memory to 8 GB.

But the Resource Manager YARN and Ambari Server Alert cannot be started. always CRIT

Please what do i miss ?

740-0001.jpg

751-0002.jpg

Thank you

yan

1 ACCEPTED SOLUTION

@yan Adiputra Just looking at your logs, looks like the problem is a wrong memory configuration:

2015-12-10 09:57:39,443 INFO  service.AbstractService (AbstractService.java:noteFailure(272)) - Service RMActiveServices failed in state INITED; cause: org.apache.hadoop.yarn.exceptions.YarnRuntimeException: Invalid resource scheduler memory allocation configuration, yarn.scheduler.minimum-allocation-mb=3072, yarn.scheduler.maximum-allocation-mb=2250, min and max should be greater than 0, max should be no smaller than min.
org.apache.hadoop.yarn.exceptions.YarnRuntimeException: Invalid resource scheduler memory allocation configuration, yarn.scheduler.minimum-allocation-mb=3072, yarn.scheduler.maximum-allocation-mb=2250, min and max should be greater than 0, max should be no smaller than min.
 at org.apache.hadoop.yarn.server.resourcemanager.scheduler.capacity.CapacityScheduler.validateConf(CapacityScheduler.java:179)
 at org.apache.hadoop.yarn.server.resourcemanager.scheduler.capacity.CapacityScheduler.initScheduler(CapacityScheduler.java:308)
 at org.apache.hadoop.yarn.server.resourcemanager.scheduler.capacity.CapacityScheduler.serviceInit(CapacityScheduler.java:348)
 at org.apache.hadoop.service.AbstractService.init(AbstractService.java:163)
 at org.apache.hadoop.service.CompositeService.serviceInit(CompositeService.java:107)
 at org.apache.hadoop.yarn.server.resourcemanager.ResourceManager$RMActiveServices.serviceInit(ResourceManager.java:572)
 at org.apache.hadoop.service.AbstractService.init(AbstractService.java:163)
 at org.apache.hadoop.yarn.server.resourcemanager.ResourceManager.createAndInitActiveServices(ResourceManager.java:972)
 at org.apache.hadoop.yarn.server.resourcemanager.ResourceManager.serviceInit(ResourceManager.java:259)
 at org.apache.hadoop.service.AbstractService.init(AbstractService.java:163)
 at org.apache.hadoop.yarn.server.resourcemanager.ResourceManager.main(ResourceManager.java:1202)

According to the logs the following config is set:

  • yarn.scheduler.maximum-allocation-mb=2250
  • yarn.scheduler.minimum-allocation-mb=3072

This config is impossible min has to be smaller than max

Could you please switch the configurations, so that you have:

  • yarn.scheduler.maximum-allocation-mb=3072
  • yarn.scheduler.minimum-allocation-mb=2250

804-screen-shot-2015-12-14-at-101418-am.png

View solution in original post

12 REPLIES 12

@yan Adiputra

Click Dashboard --> Yarn and then paste the screen shot here.

cd /var/log/hadoop-yarn and check for log files

paste resource manager entries (errors if there are any)

Thank You For the Answer

Here the screen shoot

799-yarn-001.png

and about the error there is some

2015-10-27 15:21:36,887 ERROR resourcemanager.ResourceManager (LogAdapter.java:error(69)) - RECEIVED SIGNAL 15: SIGTERM

2015-10-27 15:21:37,077 ERROR resourcemanager.ResourceManager (ResourceManager.java:run(691)) - Returning, interrupted : java.lang.InterruptedException

here the full log :

https://drive.google.com/open?id=0ByY5H-XcydgiNjRJNVliNFh6NW8

Could not access the log. Maybe post it to http://pastebin.com or https://gist.github.com?

here the file if you wanted

i cannot upload to pastebin because the file is 44 MB

https://www.dropbox.com/s/c70jir1v6re29ex/yarn-yarn-resourcemanager-sandbox.hortonworks.com.zip?dl=0

Rising Star

Hi @yan Adiputra, can you give the VM runs best with 8GB allocated to it. If you have 8GB total for your machine, try giving the VM about 6GB.

Could you please check if the RM is not still running? (process list, ps aux | grep resourcemanager)

Also make sure there is no pid-file in /var/run/hadoop-yarn/yarn/

@yan Adiputra Just looking at your logs, looks like the problem is a wrong memory configuration:

2015-12-10 09:57:39,443 INFO  service.AbstractService (AbstractService.java:noteFailure(272)) - Service RMActiveServices failed in state INITED; cause: org.apache.hadoop.yarn.exceptions.YarnRuntimeException: Invalid resource scheduler memory allocation configuration, yarn.scheduler.minimum-allocation-mb=3072, yarn.scheduler.maximum-allocation-mb=2250, min and max should be greater than 0, max should be no smaller than min.
org.apache.hadoop.yarn.exceptions.YarnRuntimeException: Invalid resource scheduler memory allocation configuration, yarn.scheduler.minimum-allocation-mb=3072, yarn.scheduler.maximum-allocation-mb=2250, min and max should be greater than 0, max should be no smaller than min.
 at org.apache.hadoop.yarn.server.resourcemanager.scheduler.capacity.CapacityScheduler.validateConf(CapacityScheduler.java:179)
 at org.apache.hadoop.yarn.server.resourcemanager.scheduler.capacity.CapacityScheduler.initScheduler(CapacityScheduler.java:308)
 at org.apache.hadoop.yarn.server.resourcemanager.scheduler.capacity.CapacityScheduler.serviceInit(CapacityScheduler.java:348)
 at org.apache.hadoop.service.AbstractService.init(AbstractService.java:163)
 at org.apache.hadoop.service.CompositeService.serviceInit(CompositeService.java:107)
 at org.apache.hadoop.yarn.server.resourcemanager.ResourceManager$RMActiveServices.serviceInit(ResourceManager.java:572)
 at org.apache.hadoop.service.AbstractService.init(AbstractService.java:163)
 at org.apache.hadoop.yarn.server.resourcemanager.ResourceManager.createAndInitActiveServices(ResourceManager.java:972)
 at org.apache.hadoop.yarn.server.resourcemanager.ResourceManager.serviceInit(ResourceManager.java:259)
 at org.apache.hadoop.service.AbstractService.init(AbstractService.java:163)
 at org.apache.hadoop.yarn.server.resourcemanager.ResourceManager.main(ResourceManager.java:1202)

According to the logs the following config is set:

  • yarn.scheduler.maximum-allocation-mb=2250
  • yarn.scheduler.minimum-allocation-mb=3072

This config is impossible min has to be smaller than max

Could you please switch the configurations, so that you have:

  • yarn.scheduler.maximum-allocation-mb=3072
  • yarn.scheduler.minimum-allocation-mb=2250

804-screen-shot-2015-12-14-at-101418-am.png

Thank You very much. i don't know Hadoop original setting must be check first.

Glad I could help. Usually these settings are correct in our sandbox and you dont have to reconfigure them after you boot the sandbox. I'll let our sandbox-team know, so they can check if there might be an issue.

Rising Star

Hi Jonas,

I checked the sandbox on latest version, by default we use a min container of 250MB and max container 2250MB.

@rmolina thanks for checking 🙂

Is there a possibility for upgrading the memory from 4GB to 8 gb?

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.