Support Questions
Find answers, ask questions, and share your expertise

Revert Cloudera Manager settings

Solved Go to solution

Revert Cloudera Manager settings

New Contributor

Hello,

 

I was setting up HTTPS for Cloudera Manager web UI when I messed up the configurations by using a keystore password that I have lost since.

Now when I try to start Cloudera Manager I get a clear exception that it cannot get the private key and it fails and stops.

 

My question is : How can I revert the configs from the Cloudera Manager server to go back to HTTP so I can setup the right HTTPS configurations without having access to Cloudera Manager web UI? Is there a configurations file that I can use ? Are these configurations saved in the Cloudera Manager database and are not easily accessible ? I just want to desactivate HTTPS so I can go back to Cloudera Manager web UI and setup the correct configs.

 

I'm using :

 

Version: Cloudera Enterprise 5.5.1 (#8 built by jenkins on 20151201-1818 git: 2a7dfe22d921bef89c7ee3c2981cb4c1dc43de7b)

 

on 

 

DISTRIB_DESCRIPTION="Ubuntu 14.04.1 LTS"

 

Best Regards,

 

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Revert Cloudera Manager settings

To turn off HTTPS for the CM UI altogether, change the config with attr "web_tls" to have value "false".

View solution in original post

3 REPLIES 3

Re: Revert Cloudera Manager settings

Hi,

You can find the username, host, port, and password to the CM database in /etc/cloudera-scm-server/db.properties. Use this to connect to the database, then find your password in the CONFIGS with an ATTR of "keystore_password". You should be able to change your keystore password to this value.

Thanks,
Darren

Re: Revert Cloudera Manager settings

New Contributor
Great thanks I'll look at the database.
By the way what is the ATTR name of the CM HTTPS config, I want to
completely disable HTTPS and go back to HTTP.

Thanks,

Re: Revert Cloudera Manager settings

To turn off HTTPS for the CM UI altogether, change the config with attr "web_tls" to have value "false".

View solution in original post