Support Questions
Find answers, ask questions, and share your expertise
Announcements
Check out our newest addition to the community, the Cloudera Innovation Accelerator group hub.

[S1000][unixODBC][SAP][DriverSupport] (1140) Unable to load CA certificates from certs file location.

New Contributor

Hello,

 

I'm trying to use a ODBC connexion with SAP BI 4.2 app, on linux environment.

 

Here are my settings : 

 

--------- odbc.ini file -----------------

[ODBC Data Sources]
Impala=Simba Impala ODBC Driver (64-bit)

[Impala_TEST]
Description=Simba Impala ODBC Driver (64-bit)
Driver=/data/BO/sap_bobj/enterprise_xi40/linux_x64/odbc/simbaimpala/2.0/lib/libimpalaodbc_sb64.so
HiveServerType=2
ServiceDiscoveryMode=0
Host=portalgps.idf.fr.gin.intraorange
Port=443
schema=default
AuthMech=4
KrbFQDN=_HOST
UID=hive
ThriftTransport=2
HttpPath=/knox/cdp-proxy-api/hive

ServiceDiscoveryMode=0
AllowSelfSignedServerCert=1
UseNativeQuery=1

SSL=1 
AllowSelfSignedCerts=1
CAIssuedCertNamesMismatch=1
TrustedCerts=/data/BO/sap_bobj/enterprise_xi40/linux_x64/odbc/simbaimpala/2.0/lib/cacerts.pem
TwoWaySSL=0

 

 

 

--------- odbcinst.ini -----------------
[ODBC Drivers]
Simba Impala ODBC Driver 64-bit=Installed
Impala_TEST=Installed

[Simba Impala ODBC Driver 64-bit]
Description=Simba Impala ODBC Driver (64-bit)
Driver=/data/BO/sap_bobj/enterprise_xi40/linux_x64/odbc/simbaimpala/2.0/lib/libimpalaodbc_sb64.so

[Impala_TEST]
Description=Simba Impala ODBC Driver (64-bit)
Driver=/data/BO/sap_bobj/enterprise_xi40/linux_x64/odbc/simbaimpala/2.0/lib/libimpalaodbc_sb64.so


------------

check that the certificate file cacerts.pem exists and is on 777 rights :

[admin@DVO1T-CMS04 bin]$ ll /data/BO/sap_bobj/enterprise_xi40/linux_x64/odbc/simbaimpala/2.0/lib/cacerts.pem
-rwxrwxrwx 1 admin admin 5844 Sep 21 16:54 /data/BO/sap_bobj/enterprise_xi40/linux_x64/odbc/simbaimpala/2.0/lib/cacerts.pem

 

 

Test with unixODBC isql :

 

[admin@DVO1T-CMS04 bin]$ isql -v Impala_TEST <myuser> <password>
[S1000][unixODBC][SAP][DriverSupport] (1140) Unable to load CA certificates from certs file location. Please ensure the file exists, has read permission, and has the correct PEM format.
[ISQL]ERROR: Could not SQLConnect

 

Does anyone know what's wrong on my setting ?

 

Thank you

1 ACCEPTED SOLUTION

New Contributor

Problem solved. Was due  to the bad format (special characters) of pem file.

 

I close the question.

View solution in original post

2 REPLIES 2

New Contributor

Nobody has the same issue ?

New Contributor

Problem solved. Was due  to the bad format (special characters) of pem file.

 

I close the question.