Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

SAS -Impala connection error : Impala Thrift API ExecuteStatement: SSL_write: Broken Pipe

avatar
Visitor

Hi Impala Team,

 

SAS BI Server - Impala DB connection set up established and end users can connect to Impala DB, Access data but often analysts are reported below scenario and error.

 

Scenario 1:  Analyst assigns SAS Impala DB library in SAS EG then run the code with assigned Impala DB library in reference to read data, that first query executes fine and when analyst wait for complete execution lets say for 5-10 min and re run the same program then gets below error.

 

Scenario 2.  Analyst expand SAS impala DB library in SAS EG then open table to have look at data, close the table then if try to open the same table or other table from same library after 5-10 min then gets below error.

 

ERROR: CLI prepare error: [Cloudera][ImpalaODBC] (450) Error when calling the Impala Thrift API ExecuteStatement: SSL_write: BrokenPipe

 

Does anyone experience the above scenario and error? can you please suggest what could be the root cause and fix for this?

 

Thank,

 

2 REPLIES 2

avatar

Hi @nagacg , 

Usually this happens (emphasis also on the "intermittent" nature) when the BI tools like SAS connects to the Impala service (impala coordinator deamons) through a load balancer. With the Load-balancer the different requests are routed to different impala coordinator deamons and likely one of the impala coordinator deamon is in bad health. In this case not all the operations are failing - just some of them, as you've described.

It is sometimes not obvious (from Cloudera Manager UI) that an impalad is unhealthy, need to verify all of them by connecting directly to them 1 by 1 with another tool, like impala-shell. (need to verify only the coordinators this way).

I would suggest to involve Cloudera Support to assist you with this.

avatar
Visitor

Hi Mszurap,

 

Thank you for your reply. yes I am worked with Cloudera team on this. 

 

Thank you .