Support Questions
Find answers, ask questions, and share your expertise

[SOLVED] Using an External Source in Cloudbreak

Hi All,

Trying to add an Azure Database for Postgres (v10). I am able to access it using psql from my host however when trying to add it to Hortonworks as an External Source gives the following issue:


Kind Regards,

Nathaniel Vala




Hi Nathaniel,

This issue discovered and fixed in Cloudbreak 2.7.2. You can update to this version easily, here are the steps:

1. Navigate to your deployment directory

2. Run the following commands:

 export CBD_VERSION=2.7.2
 curl -Ls${CBD_VERSION}_$(uname)_x86_64.tgz | tar -xz -C /bin cbd
  • $(uname) will be replaced automatically with Linux or Darwin according to the OS you are running it

> If you would like to download via browser, replace2.7.2 and $(uname) in the URL and then paste the URL in the browser and extract into the /bin directory

3.Verify the version

  cbd version 

4.Next, restart Cloudbreak by using:

  cbd restart 

Let me know if you need any help!



Hi @Gergely Topolyai, Thanks for the recommendation, I upgraded to 2.9.0 however was still not able to connect. However this time I got a more verbose message, looks like it is an Azure routing / compatibility issue.


@Nathaniel Vala This might be of help.

Thanks! This solved the issue. Once I had removed the SQL service endpoint from the VNet that hosted my cloudbreak VM everything worked fine 🙂


Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.