Support Questions

Find answers, ask questions, and share your expertise

SQOOP EXPORT error - Larger than maximum split size error


I am getting the below error while doing SQOOP EXPORT. Minimum split size pernode 536870912 cannot be larger than maximum split size 41at org.apache.sqoop.mapreduce.CombineFileInputFormat.getSplits(
at org.apache.sqoop.mapreduce.ExportInputFormat.getSplits(
at org.apache.hadoop.mapreduce.JobSubmitter.writeNewSplits(
at org.apache.hadoop.mapreduce.JobSubmitter.writeSplits(
at org.apache.hadoop.mapreduce.JobSubmitter.submitJobInternal(
at org.apache.hadoop.mapreduce.Job$
at org.apache.hadoop.mapreduce.Job$
at Method)
at org.apache.hadoop.mapreduce.Job.submit(
at org.apache.hadoop.mapreduce.Job.waitForCompletion(
at org.apache.sqoop.mapreduce.ExportJobBase.doSubmitJob(
at org.apache.sqoop.mapreduce.ExportJobBase.runJob(
at org.apache.sqoop.mapreduce.ExportJobBase.runExport(
at org.apache.sqoop.manager.SqlManager.exportTable(
at org.apache.sqoop.tool.ExportTool.exportTable(
at org.apache.sqoop.Sqoop.runSqoop(
at org.apache.sqoop.Sqoop.runTool(
at org.apache.sqoop.Sqoop.runTool(
at org.apache.sqoop.Sqoop.main(

I removed the most of the fields and renamed the table to some other name due to project compliance. Below I mentioned the Sqoop Export I used

create table sup_api_bidder_test(
id int,
name string,
vendor_id bigint)

Expert Contributor
@Mahendiran Palani Samy

You want to check the mapreduce min split and max split size. From the message it seems like the min split size is larger than the max split size.


After trying multiple options. I fixed the issue by giving the below options in SQOOP Export. I fixed the per node min split size, min rack size. Then the job ran successfully.

sqoop export \ -Dmapreduce.input.fileinputformat.split.minsize.per.rack=749983 \ -Dmapreduce.input.fileinputformat.split.minsize.per.node=749983 \ --connect jdbc:mysql:// \ --username autoenv_root \ --export-dir /user/hive/warehouse/retail_db.db/orders \ -table orders\ -P


After trying multiple options finally fixed this issue to passing per node and rack min sizes. I passed the values are parms to Sqoop like below.

sqoop export \
-Dmapreduce.input.fileinputformat.split.minsize.per.rack=749983 \
-Dmapreduce.input.fileinputformat.split.minsize.per.node=749983 \
--connect jdbc:mysql:// \
--username autoenv_root \
--export-dir /user/hive/warehouse/retail_db.db/orders \                                               
-table orders\