Support Questions
Find answers, ask questions, and share your expertise

SSL Communication failed between Hue and Impala

SSL Communication failed between Hue and Impala

Explorer

When I click impala query profile, Hue raise error.

Exception cause Self-signed certificate.

I am finding the solution.

 

 

 

bad handshake: Error([('SSL routines', 'ssl3_get_server_certificate', 'certificate verify failed')],)"

 

 

 

Current configuration in my cluster :

Impala :

 

 

Enable TLS/SSL for Impala : disabled
SSL/TLS Certificate for Impala component Webserver : Daemon, Catalog, Statestore enabled

 

 

 

I want to set PEM file path.

Where are Hue - [Impala] - [[ssl]] properties used?

 

 

3 REPLIES 3

Re: SSL Communication failed between Hue and Impala

Master Collaborator

@avengers The path can be set in Hue.ini[1] and it is controlled in CDH by safety valve setting. 

 

CM > Hue > Configuration > Hue Service Advanced Configuration Snippet (Safety Valve) for hue_safety_valve.ini

 

Please refer the doc for SSL related configuration as well: 

 

[1] https://github.com/cloudera/hue/blob/master/desktop/conf.dist/hue.ini#L1329


Cheers!
Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.

Re: SSL Communication failed between Hue and Impala

Explorer

Thanks to your answer.

I have read documents in your answer.

 

How cat  I disable Self-Signed Certificate verify?

Like this : 

[hadoop]
[[hdfs_clusters]]
[[[default]]]
ssl_cert_ca_verify=False

[[yarn_clusters]]
[[[default]]]
ssl_cert_ca_verify=False

 

 

 

 

Re: SSL Communication failed between Hue and Impala

Master Collaborator

@avengers  The parameter disables the cert check it's independent of self signed or CA signed. 

ssl_cert_ca_verify=False

 


Cheers!
Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.