Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Security Recommendation Ambari 2.7.5 and RHEL 7 conflict

Solved Go to solution
Highlighted

Security Recommendation Ambari 2.7.5 and RHEL 7 conflict

New Contributor

Hi ,

 

From Ambari 2.7.5 documentation, one of the prerequisites mentioned is to set HOSTNAME in /etc/sysconfig/network , but as per RHEL 7, /etc/sysconfig/network file is deprecated. What is your recommendation on this?

 

Thanks,

Satish.

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Security Recommendation Ambari 2.7.5 and RHEL 7 conflict

Master Collaborator

@satishjan1 The initial question is asking about setting the hostname.   The information you reference is telling you to do that, but for a different operating system.  My first response was telling you how to do it for RHEL.  

 

For your next question,  you do not have to set the hostname in /etc/sysconfig/network,  you have to do it the way required for your operating system.  See Above.   The hostname must be set, and persist after reboot.   

 

If you do not set the hostname before installing the cluster you will have unmentionable problems with services and components later on down the road.

 


 


If this answer resolves your issue or allows you to move forward, please choose to ACCEPT this solution and close this topic. If you have further dialogue on this topic please comment here or feel free to private message me. If you have new questions related to your Use Case please create separate topic and feel free to tag me in your post.  


 


Thanks,



Steven

View solution in original post

4 REPLIES 4
Highlighted

Re: Security Recommendation Ambari 2.7.5 and RHEL 7 conflict

Master Collaborator

@satishjan1 the command to set the hostname is:

 

hostnamectl set-hostname host.name.com

Depending on your OS config, you may also need to update items that may manage that hostname and the host files.  You can confirm by doing above, and then reboot.   The hostname should persist after reboot.

 

 

If this answer resolves your issue or allows you to move forward, please choose to ACCEPT this solution and close this topic. If you have further dialogue on this topic please comment here or feel free to private message me. If you have new questions related to your Use Case please create separate topic and feel free to tag me in your post.  

 

Thanks,

 

 


 


If this answer resolves your issue or allows you to move forward, please choose to ACCEPT this solution and close this topic. If you have further dialogue on this topic please comment here or feel free to private message me. If you have new questions related to your Use Case please create separate topic and feel free to tag me in your post.  


 


Thanks,



Steven

Highlighted

Re: Security Recommendation Ambari 2.7.5 and RHEL 7 conflict

New Contributor

My question was that Ambari 2.7.5 documentation has prerequisites mentioned where we have to set HOSTNAME parameter in /etc/sysconfig/network. Is it fine not to set this parameter as RED HAT 7 mentions that /etc/sysconfig/network is deprecated.

 

Without setting HOSTNAME in /etc/sysconfig/network, Ambari should work fine. Is that right?

Highlighted

Re: Security Recommendation Ambari 2.7.5 and RHEL 7 conflict

the point is to correctly set the fqdn no matter how it's done as long as it is correctly configured (it needs to be configured on all hosts in the cluster) 

/etc/sysconfig/network , network manager comands, /etc/hosts (avoiding 127.0.0.1, ::1 <-> fqdn etc... or via another admin tool  )

 

some key services need a correctly set fqdn 

(kerberos REALM trust for ex will be based on domain thus localy get fqdn . geting host instead of host.domain.etc may cause issues in many hadoop services)

Re: Security Recommendation Ambari 2.7.5 and RHEL 7 conflict

Master Collaborator

@satishjan1 The initial question is asking about setting the hostname.   The information you reference is telling you to do that, but for a different operating system.  My first response was telling you how to do it for RHEL.  

 

For your next question,  you do not have to set the hostname in /etc/sysconfig/network,  you have to do it the way required for your operating system.  See Above.   The hostname must be set, and persist after reboot.   

 

If you do not set the hostname before installing the cluster you will have unmentionable problems with services and components later on down the road.

 


 


If this answer resolves your issue or allows you to move forward, please choose to ACCEPT this solution and close this topic. If you have further dialogue on this topic please comment here or feel free to private message me. If you have new questions related to your Use Case please create separate topic and feel free to tag me in your post.  


 


Thanks,



Steven

View solution in original post

Don't have an account?
Coming from Hortonworks? Activate your account here