Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 06-12-2023 12:35 AM - edited 06-12-2023 07:17 AM
I am on a kerberized CM 7.7.1 private cloud and after watching the "Cloudera Search Training" tutorial, I'd like to create a collection with SolrCloud.
I created a configuration and was able to upload it successfully to Zookeeper:
kinit <my_username>
solrctl instancedir --create testcollection <my_local_path>
This looks alright to me:
solrctl instancedir --list
testcollection
localFSTemplate
managedTemplate
managedTemplateSecure
schemalessTemplate
schemalessTemplateSecure
Calling:
solrctl collection --create testcollection -s 1
Gives the error:
Error: A call to SolrCloud WEB APIs failed:
(there's nothing more)
I suspect it is because no secure connection is being used. I therefore try it with:
solrctl --solr https://<node with solr>:8995/solr collection --create testcollection -s 1
However, Solr cannot find the configuration:
content-security-policy: default-src 'none'; base-uri 'none'; connect-src 'self'; form-action 'self'; font-src 'self'; frame-ancestors 'none'; img-src 'self'; media-src 'self'; style-src 'self' 'unsafe-inline'; script- www-authenticate: Negotiate
... <I removed the part with my username>
{ "responseHeader":{ "status":400, "QTime":25}, "Operation create caused exception:":"org.apache.solr.common.SolrException:org.apache.solr.common.SolrException: Can not find the specified config set: testcollection", "exception":{ "msg":"Can not find the specified config set: testcollection", "rspCode":400}, "error":{ "metadata":[ "error-class","org.apache.solr.common.SolrException", "root-error-class","org.apache.solr.common.SolrException"], "msg":"Can not find the specified config set: testcollection", "code":400}}
I would be grateful for any hints, I suspect there is still a problem with our configuration.
Created 06-12-2023 10:42 PM
We were able to solve the problem provisionally by adding the following to the ZooKeeper configuration:
zk_server_java_opts: -Dzookeeper.skipACL=yes
Created 06-12-2023 10:42 PM
We were able to solve the problem provisionally by adding the following to the ZooKeeper configuration:
zk_server_java_opts: -Dzookeeper.skipACL=yes