Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on
06-13-2018
09:42 AM
- last edited on
05-12-2026
01:42 PM
by
cjervis
I have a Hbase cluster of 3 nodes.
Below are the hostnames and daemons running on that machines.
hbase2 - Hmaster,RegionServer, Datanode and Nodemanager
hbase 1 - RegionServer,Namenode,Datanode, ResourceManager, NodeManager
hbase 3 - RegionServer, Datanode and Nodemanager
The moment I enter the run start-hbase.sh script. It throws the below given error
2018-06-13 14:56:52,455 INFO [hbase2:60000.activeMasterManager] retry.RetryInvocationHandler: Exception while invoking getFileInfo of class ClientNamenodeProtocolTranslatorPB over hbase2/10.94.1.119:8020 after 11 fail over attempts. Trying to fail over after sleeping for 17938ms. java.net.ConnectException: Call From hbase2/10.94.1.119 to hbase2:8020 failed on connection exception: java.net.ConnectException: Connection refused; For more details see: http://wiki.apache.org/hadoop/ConnectionRefused.
Hmaster is not running. RegionServers are working fine
Created 06-13-2018 04:01 PM
Looks like your Namenode is not running. Start the NameNode first and then try starting HBase master.
Also, it is better to give proper hostnames instead of hbase1, hbase2 etc.
.
Please "Accept" the answer If this helps you. This will be really useful for other community users
-Aditya
Created 06-13-2018 04:01 PM
Looks like your Namenode is not running. Start the NameNode first and then try starting HBase master.
Also, it is better to give proper hostnames instead of hbase1, hbase2 etc.
.
Please "Accept" the answer If this helps you. This will be really useful for other community users
-Aditya
Created 06-14-2018 03:40 AM
@Aditya Sirna Thankyou buddy. Started Namenode and it worked fine