Support Questions

Find answers, ask questions, and share your expertise
Announcements
Celebrating as our community reaches 100,000 members! Thank you!

There is no way to get ambari UI after installation

avatar

I installed ambari and setup it with help this man: https://docs.hortonworks.com/HDPDocuments/Ambari-2.6.1.0/bk_ambari-installation/content/log_in_to_ap...

I user virtualbox on which installed centos7.

I installed ambari-server, after I started it. It started with message "Server started listening on 8080". But I can't get ambariUI at all. My inet address in ifconfig -a is "inet 10.0.2.15". So I try to ping 10.0.2.15:8080 and it messages that no such service or server. After I tried to connect via browser, it's the same. I can't get AmbariUI and I don't know how to fix it. It seems to be easy but something went wrong. After ambari installation and starting it I checked log file and everything is fine. So what's the problem can't got it.

Thank you.

1 ACCEPTED SOLUTION

avatar
Master Mentor
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login
19 REPLIES 19

avatar

The problem was because of iptables. I turn off it and it works with NAT (port forwarding)

avatar
Master Mentor

@David Manukian

Check this HCC learning rope link it should help you with the port forwarding that's the problem you are encountering

avatar
Master Mentor

@David Manukian

Can you share your local hosts entry, make sure you commented out the below

#127.0.0.1       localhost
#::1             localhost

Please revert

avatar
Master Mentor

@David Manukian

My previous hosts file was from my windows laptop I am not conversant with Macbooks 🙂


MacOSFirewall setting

Go to System Preferences, Security & Privacy, Firewall, Firewall Options...

see attached screenshot

Your ambari UI should be accessible

http://192.168.0.75:8080 or http://ambari.training:8080


Port forwarding

Quite simple to do, Firstly you will need to enable the remote login service on your mac (System Preferences -> Sharing -> Remote Login). This starts your ssh server. Then run the following command in your OS X Terminal: The format is thus basically:

ssh -L local_addr:local_port:remote_addr:remote_port -N 127.0.0.1 

example

ssh -L 200.234.XXX.XXX:10000:10.211.55.5:80 -N 127.0.0.1 

You may need to accept the server fingerprint initially as well as type in your local password for ssh login. (You can also set up a local to local ssh public/private key to make it not prompt for a password, but that it a different exercise.)

avatar

My ssh works fine. The trouble in another. In virtualmachine curl works fine with port 8080, I really see it works. So, from local machine I make ping to virtualmachine and it works also but when I put port with host it doesnt work. I can't understand what's wrong it really makes me stupid lol. I even add hostonly network it means that no problem in communication localmachine to virtual but anyway with port it doesnt work.

avatar

Noway to connect to ambari from local browser, just noway.

avatar

Firewall and other gateway is off on my mac.

avatar

64676-screen-shot-2018-03-18-at-035100.png

it's via ssh in virtualbox. See that ambari works in virtualmachine but when I try to connect from local it doesn't see

avatar
Master Mentor

@David Manukian

That's the image I forgot to attach sorry


macos.jpg

avatar

It didn't help.