Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

Trigger email alerts on processor failures in Nifi process group

avatar
New Contributor

I have a pipeline running on a daily basis, I wish to receive an email alert whenever any of the processor fails. I tried testing put email processor, I am receiving success flow files after PutEmail but email is not being generated despite entering correct SMTP details. Kindly suggest if I am missing on anything. 

My nifi pipeline flow is as follows :

getMongo > flatteJson > evaluateJsonPath > attributeToJson > queryRecord > updateAttribute > PutS3

For eg : If I get an error in QueryRecord : column 'x' not found in list of columns. This failure alert should be sent on my email.

PFB the properties I have used for configuration of PutEmail processor

Jaimin7_0-1681219196604.png

Jaimin7_1-1681219234297.png

 

1 REPLY 1

avatar

Hi @Jaimin7,

I am not quite sure how your SMTP Server is configured, but everywhere I have implemented the PutEmail processors, I needed 5 mandatory properties:

1) SMTP Hostname
2) SMTP Port
3) SMTP Username (even though in NiFi it is not a mandatory field, it was a mandatory field for the STMP to allow the connection)
4) SMTP Password (even though in NiFi it is not a mandatory field, it was a mandatory field for the STMP to allow the connection)
5) From.

cotopaul_0-1681226288437.png

 

Having all these fields configured, I was able to send email from NiFi without any restrictions. Of course, I made sure that the firewall connection between NiFi and the SMTP Server is allowing such connections 🙂