Support Questions

Find answers, ask questions, and share your expertise
Announcements
Celebrating as our community reaches 100,000 members! Thank you!

Trying to deploy Apache Metron on single node VM, but Ansible and maven dependency failures, please help I am stuck

avatar
Explorer

Hi,

I am trying to deploy Apache Metron on a single node VM, but after vagrant up, when I run vagrant provision, it gives me errors on maven dependencies and ansible failed to setup successfully.

I have installed all packages defined for Metron deployment, Ansible 2.0.0.2, Vagrant 1.9.6, Maven 3.3.9, Virtual Box 5.1.30 JDK 1.8 and Python 2.7.5

Also, when I run the command "mvn clean package", metron-config error pops up and it doesnt complete its installation, followed by metron-rest, metron-rest client

1 ACCEPTED SOLUTION

avatar
Super Collaborator
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login
60 REPLIES 60

avatar
Super Collaborator

@Gaurav Bapat is this on the new setup with increased RAM ?

avatar
Explorer

No, current system config is i5 (4 Cores) and 13 GB RAM for VM

What is the recommended system requirements?

avatar
Super Collaborator

I would recommend increasing to 16 GB RAM since you seem to be having issues with 13 GB.

avatar
Explorer

@asubramanian

Why am I facing heartbeat issue over all services??

43778-capture69.jpg

avatar
Explorer
@asubramanian

How do I configure Apache NiFi in ambari ? I cant find the option of NiFi

avatar
Explorer

@asubramanian

How do I solve this errors??

43805-capture73.jpgMy services go down and when I restart them they fail to go up

A

avatar
New Contributor

software

When I restarted my VM, same errors are popping up, like - mvn dependencies, do I need to enter mvn clean packages -Dskiptests everytime and which is the best directory for the same?

Also I am attaching step 3, please let me know how to setup SSH private key?

avatar
Explorer
@asubramanian

43810-capture74.jpg

I checked the logs and it seems there is a SSL connection error, please help me with the steps for the same??

avatar
Explorer
@asubramanian

43832-capture83.jpg

43833-capture84.jpg

I have got these two logs of ambari-agent and ambari-server, please help with the steps to fix the problem.

43834-capture68.jpg

Also, I am losing heartbeats on all components , what might be the issue ??

avatar
Explorer

@asubramanian

43835-capture85.jpg

From where do I download stable Metron Directory?