Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Unable to curl the SSl enabled NIFI URL

Unable to curl the SSl enabled NIFI URL

Hi Team,

 

I am unable to curl the NIFI SSL enabled and tried providing cert but nothing works. Kindly help me to fix this issue.

 


curl --cert-type P12 --cert keystore.p12:password --cacert nifi-cert.pem -v https://w0lxqhdp04:9091/nifi-api/flow/search-results?q=

About to connect() to w0lxqhdp04 port 9091 (#0)
* Trying 10.49.70.16...
* Connected to w0lxqhdp04 (10.49.70.16) port 9091 (#0)
* Initializing NSS with certpath: sql:/etc/pki/nssdb
* CAfile: nifi-cert.pem
CApath: none
* warning: certificate file name "keystore.p12" handled as nickname; please use "./keystore.p12" to force file name
* NSS: client certificate not found: keystore.p12
* NSS error -12271 (SSL_ERROR_BAD_CERT_ALERT)
* SSL peer cannot verify your certificate.
* Closing connection 0
curl: (58) NSS: client certificate not found: keystore.

2 REPLIES 2
Highlighted

Re: Unable to curl the SSl enabled NIFI URL

@MattWho  Please look into this 

Highlighted

Re: Unable to curl the SSl enabled NIFI URL

Master Guru

@saivenkatg55 

 

You need to literally use ./keystore.p12 in your command instead of just keystore.p12

curl --cert-type P12 --cert ./keystore.p12:password --cacert nifi-cert.pem -v https://w0lxqhdp04:9091/nifi-api/flow/search-results?q=

 

 

Hope this helps,

Matt

Don't have an account?
Coming from Hortonworks? Activate your account here