Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

Unable to install ECS container for Data Services

avatar
Explorer

Hello all,

I am installing Data Services with Embedded Container Service. There are 2 dedicated servers: 1 ECS server, 1 ECS agent. First installation run not good, always stuck at this task:

Nghia_0-1655436049401.png

Waiting for process rke-wait
+ kubectl taint node -l ecs_role=master node-role.kubernetes.io/control-plane-
taint "node-role.kubernetes.io/control-plane" not found
taint "node-role.kubernetes.io/control-plane" not found
+ true
+ sleep 10
+ /var/lib/rancher/rke2/bin/kubectl --kubeconfig /etc/rancher/rke2/rke2.yaml get nodes -o 'jsonpath={range .items[*]}{@.metadata.name}:{range @.status.conditions[*]}{@.type}={@.status};{end}{end}'
+ grep Ready=True
++ hostname -f
+ grep instance-20220615-1150.subnet06081614.vcn06081614.oraclevcn.com
+ echo ...
+ [[ ! -z true ]]
+ kubectl taint node -l ecs_role=master node-role.kubernetes.io/control-plane-
taint "node-role.kubernetes.io/control-plane" not found
taint "node-role.kubernetes.io/control-plane" not found
+ true

 

Anyone face this familiar issue before? how can i fix it?

Any advise is good for me

Thanks in advance

2 REPLIES 2

avatar
Explorer

I resolve this problem by reinstallation. Check java 11, selinux, hostname, etc,.. And now all services is up. But I cannot register environment, on monitoring dashboad in Management console, there is a alert: KubeJobFailed: Job cdp/cli failed to complete. So I check log on pod run cdp-cli, and it show: 

HTTPSConnectionPool(host='console-cdp.apps.apps.katalyst.vn', port=443): Max retries exceeded with url: /api/v1/environments2/createPrivateEnvironment (Caused by NewConnectionError('<cdpcli.cdprequest.CdpHTTPSConnection object at 0x7f7fabbd5250>: Failed to establish a new connection: [Errno -2] Name or service not known'))
Nghia_0-1656063241453.png

 

Any advise is good for me

Thanks in advance

avatar
Explorer

This issue is about DNS configuration. Kubernetes dns and my cloud dns is weird. So i have setup a dedicated server for DNS. And it is now good. I also deploy ML workspace successfully. But i got errors with CDE service: unmounted volumes=cm-root-ca-cert because configmap \"clientconfigs-default-tls-pem\" not found

Nghia_0-1657252097194.png

 

So again, Any advice would be appreciated greatly 😄