Support Questions
Find answers, ask questions, and share your expertise
Announcements
Check out our newest addition to the community, the Cloudera Innovation Accelerator group hub.

Unable to open Resource Manger UI after Kerberezing the cluster

Explorer

Ambari : 2.7.4

HDP : 3.1.4.0-315

 

Hi everyone,

Recently after kerberizing my cluster, I am unable to access my Resource Manager UI. Whenever I hit on the resource manager link on Ambari, it shows up the following error :

 

 

Please help me out to resolve this issue as soon as possible.

@KuldeepK @Shelton @jsensharma 

 

1 ACCEPTED SOLUTION

Super Collaborator

In HDP 3.x Spenego authentication will be enabled by default when you enable Kerberos

To access the UI you need to either configure Spnego auth in the browser OR disable spnego auth by setting the below  properties in Hdfs =>Advanced core-site

 

hadoop.http.authentication.simple.anonymous.allowed = true
hadoop.http.authentication.type = simple

 

View solution in original post

4 REPLIES 4

Explorer

HTTP ERROR 401
Problem accessing /ui2/. Reason:
      Unauthorized access

 

Super Collaborator

In HDP 3.x Spenego authentication will be enabled by default when you enable Kerberos

To access the UI you need to either configure Spnego auth in the browser OR disable spnego auth by setting the below  properties in Hdfs =>Advanced core-site

 

hadoop.http.authentication.simple.anonymous.allowed = true
hadoop.http.authentication.type = simple

 

Explorer

@Scharan thanks a lot for replying.

The solution you suggested worked! But I just wanted to know whether modifying those two properties as you mentioned will cause any decrease in the security of my HDFS or cluster anyway?

Super Collaborator

@bvishal given properties will disable authentication for webui's and it will allow anonymous users to access the web UI's of hdfs, yarn, and mapreduce.