Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

Unable to run [DFS] command in beeline

avatar
Expert Contributor

Hi,

In the kerberized cluster, after enabling Ranger Hive plug-in in HDP 2.6.5, not able to run dfs commands in beeline.

jdbc:hive2://test.xyz.com:10000> dfs -ls /;

Error: Error while processing statement: Permission denied: user [user1] does not have privilege for [DFS] command (state=,code=1)

Please help on this.

Thank you.



1 ACCEPTED SOLUTION

avatar
Master Guru

@Sampath Kumar

As you have enabled Ranger authorization then DFS commands are restricted in Hive when authorization is enabled.

View solution in original post

2 REPLIES 2

avatar
Master Guru

@Sampath Kumar

As you have enabled Ranger authorization then DFS commands are restricted in Hive when authorization is enabled.

avatar
Expert Contributor

Hi @Shu - Thanks for your response. Is there any way where we can enable the DFS commands where Ranger authorization is enabled?

As of now, dfs commands are working in hive shell but not in beeline.

Thank you.