Support Questions
Find answers, ask questions, and share your expertise

Unable to run hbase hbck.

Explorer

I get out of memory execption

OpenJDK 64-Bit Server VM warning: INFO: os::commit_memory(0x00007fb9c6000000, 34795945984, 0) failed; error='Cannot allocate memory' (errno=12) # # There is insufficient memory for the Java Runtime Environment to continue. # Native memory allocation (mmap) failed to map 34795945984 bytes for committing reserved memory. # An error report file with more information is saved as: # /var/log/hbase/hs_err_pid14895.log

5 REPLIES 5

Re: Unable to run hbase hbck.

Mentor

@prarthana basgod

Without your memory settings its difficult to help but generally your can run the below command to temporarily set the memory

sudo -u hbase HBASE_HEAPSIZE=10G hbase hbck -fix

Please revert

Re: Unable to run hbase hbck.

Explorer

@Geoffrey Shelton Okot I tried that..but that did not help. I have attached the log that has more infohs-err-pid19844.txt

Re: Unable to run hbase hbck.

Mentor

@prarthana basgod

Can you share /var/log/hbase/hs_err_pid14895.log

Re: Unable to run hbase hbck.

Explorer
@Geoffrey Shelton Okot

I have attached the loghs-err-pid14895.txt .

Thanks in advance.

Re: Unable to run hbase hbck.

Expert Contributor

Error shows process is not able to get the required memory from system.

Ideally HBASE_HEAPSIZE should have helped.

By default, hbase hbck will use default heap size of JVM which is usually ~1GB.

You can try setting below option and then try executing hbck.

export _JAVA_OPTIONS="-Xmx1024m -Xms1024m"

hbase hbck

Note : You can try different values of heap in _JAVA_OPTIONS